summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-06-26 21:17:35 +0000
committerThomas Deutschmann <whissi@gentoo.org>2020-06-27 00:59:53 +0200
commite871aa4cb418e91b28592acdc08263bfa13f416f (patch)
tree8c3bfd5231445ec8c943e0718b7d389adafbf563 /dev-db/percona-xtrabackup/files
parentdev-db/percona-xtrabackup: bump to 2.4.20 (diff)
downloadgentoo-e871aa4cb418e91b28592acdc08263bfa13f416f.tar.gz
gentoo-e871aa4cb418e91b28592acdc08263bfa13f416f.tar.bz2
gentoo-e871aa4cb418e91b28592acdc08263bfa13f416f.zip
dev-db/percona-xtrabackup: bump to 8.0.13, drop old
Closes: https://bugs.gentoo.org/722266 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16438 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-db/percona-xtrabackup/files')
-rw-r--r--dev-db/percona-xtrabackup/files/percona-xtrabackup-8.0.13-remove-rpm.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-db/percona-xtrabackup/files/percona-xtrabackup-8.0.13-remove-rpm.patch b/dev-db/percona-xtrabackup/files/percona-xtrabackup-8.0.13-remove-rpm.patch
new file mode 100644
index 000000000000..759598637a82
--- /dev/null
+++ b/dev-db/percona-xtrabackup/files/percona-xtrabackup-8.0.13-remove-rpm.patch
@@ -0,0 +1,32 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1b9865e2..e3c82cdd 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -181,27 +181,6 @@ ENDIF()
+ OPTION(FORCE_UNSUPPORTED_COMPILER "Disable compiler version checks" OFF)
+ MARK_AS_ADVANCED(WITHOUT_SERVER FORCE_UNSUPPORTED_COMPILER)
+
+-# Use 'uname -r' and 'rpm -qf /' to figure out host system.
+-# For Docker images we cannot trust uname, so use rpm instead.
+-IF(UNIX)
+- FIND_PROGRAM(MY_UNAME uname /bin /usr/bin /usr/local/bin /sbin)
+- IF(MY_UNAME)
+- EXECUTE_PROCESS(COMMAND ${MY_UNAME} -s
+- OUTPUT_VARIABLE MY_HOST_SYSTEM_NAME
+- OUTPUT_STRIP_TRAILING_WHITESPACE
+- RESULT_VARIABLE MY_UNAME_RESULT
+- )
+- ENDIF()
+- FIND_PROGRAM(MY_RPM rpm /bin /usr/bin)
+- IF(MY_RPM)
+- EXECUTE_PROCESS(COMMAND ${MY_RPM} -qf /
+- OUTPUT_VARIABLE MY_HOST_FILESYSTEM_NAME
+- OUTPUT_STRIP_TRAILING_WHITESPACE
+- RESULT_VARIABLE MY_RPM_RESULT
+- )
+- ENDIF()
+-ENDIF()
+-
+ IF(CMAKE_HOST_UNIX AND NOT FORCE_UNSUPPORTED_COMPILER
+ AND NOT CMAKE_C_COMPILER AND NOT CMAKE_CXX_COMPILER)
+ # Cannot INCLUDE(CMakeDetermineSystem) prior to PROJECT initialization below.