summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiuseppe Foti <foti.giuseppe@gmail.com>2023-05-20 19:09:48 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-07-03 10:15:22 +0200
commitef7938851459eb69c45659805cbb00f4e3677a12 (patch)
treea44539164343c35189e30cf340a6996f58a452c1 /dev-db/pg-gvm
parentnet-analyzer/gvm-tools: add 23.4.0 (diff)
downloadgentoo-ef7938851459eb69c45659805cbb00f4e3677a12.tar.gz
gentoo-ef7938851459eb69c45659805cbb00f4e3677a12.tar.bz2
gentoo-ef7938851459eb69c45659805cbb00f4e3677a12.zip
dev-db/pg-gvm: new package, add 22.5.1
Signed-off-by: Giuseppe Foti <foti.giuseppe@gmail.com> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-db/pg-gvm')
-rw-r--r--dev-db/pg-gvm/Manifest1
-rw-r--r--dev-db/pg-gvm/files/README.gentoo10
-rw-r--r--dev-db/pg-gvm/metadata.xml21
-rw-r--r--dev-db/pg-gvm/pg-gvm-22.5.1.ebuild38
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-db/pg-gvm/Manifest b/dev-db/pg-gvm/Manifest
new file mode 100644
index 000000000000..c31563a623c8
--- /dev/null
+++ b/dev-db/pg-gvm/Manifest
@@ -0,0 +1 @@
+DIST pg-gvm-22.5.1.tar.gz 38657 BLAKE2B e4c29e67650c101762157229dce7fa390f456e37d52ebc0f9c05beda8d5da8c11342857c87377b7bedc5e9e2d33c24b7f8a24e75fbce7cc5a28015d9d9235075 SHA512 aff713d9adceb6dedd4857acd70562bac80d024125637d47883d96bcfd47aa5cd0669c65d69dd307805bd3199a67ca76569cc1a65e19ea391b2c61fe8d359a82
diff --git a/dev-db/pg-gvm/files/README.gentoo b/dev-db/pg-gvm/files/README.gentoo
new file mode 100644
index 000000000000..1e751010d077
--- /dev/null
+++ b/dev-db/pg-gvm/files/README.gentoo
@@ -0,0 +1,10 @@
+To use the extension in a database create the extension using
+CREATE EXTENSION "pg-gvm";
+
+You can do this on the gvmd database running:
+
+root ~ # sudo -u postgres psql gvmd
+gvmd=> CREATE EXTENSION "pg-gvm";
+gvmd=> \q
+
+Please, read: https://github.com/greenbone/pg-gvm/#use-the-extension
diff --git a/dev-db/pg-gvm/metadata.xml b/dev-db/pg-gvm/metadata.xml
new file mode 100644
index 000000000000..807b4ad17d4f
--- /dev/null
+++ b/dev-db/pg-gvm/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>foti.giuseppe@gmail.com</email>
+ <name>Giuseppe Foti</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Greenbone Library for ical functions. This library contains functionality for ical object manipulation.
+ This is a PostgreSQL server extension that adds several functions used by gvmd, e.g., iCalendar and host
+ range evaluation. In previous versions, of GVM these functions were managed directly by gvmd while
+ pg-gvm uses the extension management built into PostgreSQL.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">greenbone/pg-gvm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/pg-gvm/pg-gvm-22.5.1.ebuild b/dev-db/pg-gvm/pg-gvm-22.5.1.ebuild
new file mode 100644
index 000000000000..2865140dcd0e
--- /dev/null
+++ b/dev-db/pg-gvm/pg-gvm-22.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake readme.gentoo-r1
+
+DESCRIPTION="Greenbone Library for helper functions in PostgreSQL"
+HOMEPAGE="https://www.greenbone.net https://github.com/greenbone/pg-gvm"
+SRC_URI="https://github.com/greenbone/pg-gvm/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+
+# Tests requires a running database that match up with the current
+# testing slot. Won't run from ${ED}, want's to install too early.
+RESTRICT="test"
+
+DEPEND="
+ >=dev-libs/glib-2.42:2
+ >=dev-libs/libical-1.0.0:=
+ >=net-analyzer/gvm-libs-22.6
+"
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-db/postgresql-9.6[uuid]
+"
+
+src_install() {
+ cmake_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}