summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-04-17 08:10:34 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-04-17 08:11:02 +0100
commit71d36e07809ca476f3ecd93bf79a91e1e4b7068e (patch)
tree6fec5072926223ecac20fbdce8a0a1eb7fe96711 /dev-embedded
parentdev-libs/flatbuffers: x86 stable wrt bug #717762 (diff)
downloadgentoo-71d36e07809ca476f3ecd93bf79a91e1e4b7068e.tar.gz
gentoo-71d36e07809ca476f3ecd93bf79a91e1e4b7068e.tar.bz2
gentoo-71d36e07809ca476f3ecd93bf79a91e1e4b7068e.zip
dev-embedded/u-boot-tools: bump up to 2020.04
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/u-boot-tools/Manifest1
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2020.04.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-embedded/u-boot-tools/Manifest b/dev-embedded/u-boot-tools/Manifest
index 39c72b495be5..8af2fb54a307 100644
--- a/dev-embedded/u-boot-tools/Manifest
+++ b/dev-embedded/u-boot-tools/Manifest
@@ -1,2 +1,3 @@
DIST u-boot-2019.10.tar.bz2 14214608 BLAKE2B 0dc89ebe207f836d2430d5111def9b4efa22839311d28cbfe4f0387a1b211850b0bf3cd67440b3cc32fb23aa8ece270c2438c44f5432f72474b4802ff117e803 SHA512 d8e98fca4b6af8d49d20ec09beab16b77863fcee88cda3605cc14435de21030bf3ca5e7cf7d06e42d4c0f75279c7295ecd628d2b77666eff7b7fd50374e051fd
DIST u-boot-2020.01.tar.bz2 14716125 BLAKE2B a2860f74cd3b147d39ed55ba4745e0400e19889a772f21d4bb18be9bdca9b43c6542b2b750207421f87b155529ddb38ea52b2820b46fdbd76232cdd6c13085cd SHA512 073d4e0234095c1bda1ffa7a648972aa4530d106ee1a73035e0501b1aba2951653582c8b7bcf338d4e95012fa67e75f97b7e1fbac5cc764d609b671ef29617f7
+DIST u-boot-2020.04.tar.bz2 15065656 BLAKE2B 29cf8be6027ce46e3bf3fae9b6736e6aba46dba2904112f845d79f50b52b7c7ff3437c71dac6ab22d112347467fb5baaa3ec421cb842ba3ae9b547e4f8378d03 SHA512 e04fe54883149123730605b084324ac0d1d72ce6913467bbe587a5a2675bcf7bb393405d9a446dc0c64ba42abc1e862ae5a132e9e51aa7390e2e9fce045af8d8
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2020.04.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2020.04.ebuild
new file mode 100644
index 000000000000..6deafb7f05c9
--- /dev/null
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2020.04.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="u-boot-${PV/_/-}"
+DESCRIPTION="utilities for working with Das U-Boot"
+HOMEPAGE="https://www.denx.de/wiki/U-Boot/WebHome"
+SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ sys-devel/flex
+ sys-devel/bison
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ # Unset a few KBUILD variables. Bug #540476
+ unset KBUILD_OUTPUT KBUILD_SRC
+
+ emake \
+ V=1 \
+ HOSTCC="$(tc-getCC)" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ tools-only_defconfig
+
+ emake \
+ V=1 \
+ NO_SDL=1 \
+ HOSTSTRIP=: \
+ STRIP=: \
+ HOSTCC="$(tc-getCC)" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ CONFIG_ENV_OVERWRITE=y \
+ tools-all
+}
+
+src_test() { :; }
+
+src_install() {
+ cd tools || die
+ dobin bmp_logo dumpimage fdtgrep gen_eth_addr img2srec mkenvimage mkimage
+ dobin env/fw_printenv
+ dosym fw_printenv /usr/bin/fw_setenv
+ insinto /etc
+ doins env/fw_env.config
+ doman "${S}"/doc/mkimage.1
+}