summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Żołnowski <aidecoe@gentoo.org>2016-06-06 23:18:43 +0100
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2016-06-07 23:20:46 +0100
commit10d4c9eefbbab6ba9ff99d6ec85bd09b76d349e2 (patch)
treeb3641a9f905cf737edfa6ec4a6691902d23aac86 /dev-erlang/protobuffs/protobuffs-0.8.2.ebuild
parentdev-erlang/proper: Add new package (diff)
downloadgentoo-10d4c9eefbbab6ba9ff99d6ec85bd09b76d349e2.tar.gz
gentoo-10d4c9eefbbab6ba9ff99d6ec85bd09b76d349e2.tar.bz2
gentoo-10d4c9eefbbab6ba9ff99d6ec85bd09b76d349e2.zip
dev-erlang/protobuffs: Add new package
It is debundled from net-im/ejabberd-16.04 and therefore inherits keywords from ejabberd: ~amd64, ~arm, ~ppc and ~x86. ~ia64 and ~sparc are not inherited because other dependency is missing these keywords and there's no chance it can get them any time soon. Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-erlang/protobuffs/protobuffs-0.8.2.ebuild')
-rw-r--r--dev-erlang/protobuffs/protobuffs-0.8.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-erlang/protobuffs/protobuffs-0.8.2.ebuild b/dev-erlang/protobuffs/protobuffs-0.8.2.ebuild
new file mode 100644
index 000000000000..38065c80ded7
--- /dev/null
+++ b/dev-erlang/protobuffs/protobuffs-0.8.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit rebar
+
+MY_PN="erlang_protobuffs"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Google's Protocol Buffers for Erlang"
+HOMEPAGE="https://github.com/basho/erlang_protobuffs"
+SRC_URI="https://github.com/basho/${MY_PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-lang/erlang-17.1"
+DEPEND="${CDEPEND}
+ test? (
+ >=dev-erlang/meck-0.8.2
+ >=dev-erlang/proper-1.1
+ )"
+RDEPEND="${CDEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.markdown )
+
+S="${WORKDIR}/${MY_P}"
+
+src_test() {
+ ./scripts/generate_emakefile.escript || die
+ erebar ct
+ # FIXME: 1 test fails, reported upstream:
+ # FIXME: https://github.com/basho/erlang_protobuffs/issues/100
+ # FIXME: erebar eunit
+}