summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:06:44 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:23 +0100
commit1953a2587869954bf53b66fd4ffd6e30ceb32092 (patch)
tree612ca503cbee6cc7f909cdef68cb8519397be524 /dev-haskell/conduit/conduit-1.3.4.3.ebuild
parentdev-haskell/conduit-extra: add 1.3.6-r1 (diff)
downloadgentoo-1953a2587869954bf53b66fd4ffd6e30ceb32092.tar.gz
gentoo-1953a2587869954bf53b66fd4ffd6e30ceb32092.tar.bz2
gentoo-1953a2587869954bf53b66fd4ffd6e30ceb32092.zip
dev-haskell/conduit: add 1.3.4.3
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/conduit/conduit-1.3.4.3.ebuild')
-rw-r--r--dev-haskell/conduit/conduit-1.3.4.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/conduit/conduit-1.3.4.3.ebuild b/dev-haskell/conduit/conduit-1.3.4.3.ebuild
new file mode 100644
index 000000000000..be625410fa1d
--- /dev/null
+++ b/dev-haskell/conduit/conduit-1.3.4.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Streaming data processing library"
+HOMEPAGE="https://github.com/snoyberg/conduit"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/mono-traversable-1.0.7:=[profile?]
+ dev-haskell/primitive:=[profile?]
+ >=dev-haskell/resourcet-1.2:=[profile?] <dev-haskell/resourcet-1.3:=[profile?]
+ dev-haskell/unliftio-core:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? ( >=dev-haskell/hspec-1.3
+ >=dev-haskell/quickcheck-2.7
+ dev-haskell/safe
+ dev-haskell/silently
+ >=dev-haskell/split-0.2.0.0
+ >=dev-haskell/unliftio-0.2.4.0 )
+"