summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/editline
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/editline')
-rw-r--r--dev-haskell/editline/Manifest1
-rw-r--r--dev-haskell/editline/editline-0.2.1.1.ebuild31
-rw-r--r--dev-haskell/editline/files/editline-0.2.1.1-ghc-7.8.patch13
-rw-r--r--dev-haskell/editline/metadata.xml8
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-haskell/editline/Manifest b/dev-haskell/editline/Manifest
new file mode 100644
index 000000000000..77123f7a210b
--- /dev/null
+++ b/dev-haskell/editline/Manifest
@@ -0,0 +1 @@
+DIST editline-0.2.1.1.tar.gz 47240 SHA256 9fb64f89a38ad847de7d3537e9dff75d8fcebd12fc789a175cc892a0e4873f80 SHA512 c4fa4438ecf318637ff42292411024f9df86d3edab5ac2107fe3978a9778ce03f62348fc4cf9c5a2f06e74e1abf0c8963f5a6d686113ba31a5c59fd7a75295d6 WHIRLPOOL 4b254eabcf6edb0d20a2bf7546b628656fd1dc5009cf1684c74b8871fa3d0402f3acdde3ec00bc69c9d43c44d2c6432fc92b8429ec7b87f28976c2407ecee909
diff --git a/dev-haskell/editline/editline-0.2.1.1.ebuild b/dev-haskell/editline/editline-0.2.1.1.ebuild
new file mode 100644
index 000000000000..4446a4245510
--- /dev/null
+++ b/dev-haskell/editline/editline-0.2.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+DESCRIPTION="Bindings to the editline library (libedit)"
+HOMEPAGE="http://code.haskell.org/editline"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:=
+ dev-libs/libedit"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.8.patch
+
+ cabal_chdeps \
+ 'base < 4.7' 'base'
+}
diff --git a/dev-haskell/editline/files/editline-0.2.1.1-ghc-7.8.patch b/dev-haskell/editline/files/editline-0.2.1.1-ghc-7.8.patch
new file mode 100644
index 000000000000..4a55ecd5626b
--- /dev/null
+++ b/dev-haskell/editline/files/editline-0.2.1.1-ghc-7.8.patch
@@ -0,0 +1,13 @@
+diff --git a/System/Console/Editline/Readline.hsc b/System/Console/Editline/Readline.hsc
+index 1ea9d6c..3b95b59 100644
+--- a/System/Console/Editline/Readline.hsc
++++ b/System/Console/Editline/Readline.hsc
+@@ -173,7 +173,7 @@ import Foreign.Marshal.Array ( mallocArray, peekArray0, pokeArray0 )
+ import Foreign.C.Types ( CInt(..), CChar, CFile )
+ import Foreign.C.String ( newCString, peekCString, withCString,
+ castCharToCChar, castCCharToChar )
+-import GHC.Handle ( fdToHandle )
++import GHC.IO.Handle.FD ( fdToHandle )
+
+ {-# CFILES HsReadline_cbits.c #-}
+
diff --git a/dev-haskell/editline/metadata.xml b/dev-haskell/editline/metadata.xml
new file mode 100644
index 000000000000..8c66906af531
--- /dev/null
+++ b/dev-haskell/editline/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>haskell</herd>
+<maintainer>
+ <email>haskell@gentoo.org</email>
+</maintainer>
+</pkgmetadata>