summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 21:03:20 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 21:57:00 +0000
commitfa695683df9c790988953be2d68250b98e14abb1 (patch)
treea17a660ce75a6c8bb15a2f6514ec6b9012bae941 /dev-haskell/http-client-tls/http-client-tls-0.3.3.ebuild
parentdev-haskell/http-client: bump up to 0.5.5 (diff)
downloadgentoo-fa695683df9c790988953be2d68250b98e14abb1.tar.gz
gentoo-fa695683df9c790988953be2d68250b98e14abb1.tar.bz2
gentoo-fa695683df9c790988953be2d68250b98e14abb1.zip
dev-haskell/http-client-tls: bump up to 0.3.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/http-client-tls/http-client-tls-0.3.3.ebuild')
-rw-r--r--dev-haskell/http-client-tls/http-client-tls-0.3.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/http-client-tls/http-client-tls-0.3.3.ebuild b/dev-haskell/http-client-tls/http-client-tls-0.3.3.ebuild
new file mode 100644
index 000000000000..2f780a972ea6
--- /dev/null
+++ b/dev-haskell/http-client-tls/http-client-tls-0.3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="http-client backend using the connection package and tls library"
+HOMEPAGE="https://github.com/snoyberg/http-client"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # needs network access
+
+RDEPEND="dev-haskell/case-insensitive:=[profile?]
+ >=dev-haskell/connection-0.2.2:=[profile?]
+ dev-haskell/cryptonite:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ dev-haskell/exceptions:=[profile?]
+ >=dev-haskell/http-client-0.5.0:=[profile?]
+ dev-haskell/http-types:=[profile?]
+ dev-haskell/memory:=[profile?]
+ dev-haskell/network:=[profile?]
+ >=dev-haskell/tls-1.2:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/hspec )
+"