summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-08 21:48:24 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-10 16:13:47 +0100
commitcdc0774a75c8eecd1d68d2b0b1687884b88b9331 (patch)
tree9b77a5773bcffa670927e93a4a1d38456520b488 /dev-haskell/primitive
parentapp-i18n/man-pages-pl: drop old EAPI (diff)
downloadgentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.gz
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.bz2
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.zip
*/*: Inline mirror://hackage and update URIs
This change inlines mirror://hackage in all ebuilds, and updates URIs to the modern form (old URIs redirect to that). The change has been made using the following command: find -name '*.ebuild' -exec sed -r -i \ -e 's@mirror://hackage/@https://hackage.haskell.org/@g' \ -e 's@https://hackage.haskell.org/packages/archive/([^/]*)/([^/]*)/@https://hackage.haskell.org/package/\1-\2/@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{PV}@${P}@g' \ -e '/hackage\.haskell\.org/s@\$\{MY_PN}-\$\{PV}@${MY_P}@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{MY_PV}@${MY_P}@g' \ {} + Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-haskell/primitive')
-rw-r--r--dev-haskell/primitive/primitive-0.4.1.ebuild4
-rw-r--r--dev-haskell/primitive/primitive-0.5.0.1.ebuild4
-rw-r--r--dev-haskell/primitive/primitive-0.5.1.0.ebuild4
-rw-r--r--dev-haskell/primitive/primitive-0.5.4.0.ebuild4
-rw-r--r--dev-haskell/primitive/primitive-0.6.1.0-r1.ebuild4
5 files changed, 10 insertions, 10 deletions
diff --git a/dev-haskell/primitive/primitive-0.4.1.ebuild b/dev-haskell/primitive/primitive-0.4.1.ebuild
index cdceec34b8b1..81891c6d9e5e 100644
--- a/dev-haskell/primitive/primitive-0.4.1.ebuild
+++ b/dev-haskell/primitive/primitive-0.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# ebuild generated by hackport 0.2.13
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Wrappers for primitive operations"
HOMEPAGE="http://code.haskell.org/primitive"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
diff --git a/dev-haskell/primitive/primitive-0.5.0.1.ebuild b/dev-haskell/primitive/primitive-0.5.0.1.ebuild
index 33434c165ee1..abb4e8a33586 100644
--- a/dev-haskell/primitive/primitive-0.5.0.1.ebuild
+++ b/dev-haskell/primitive/primitive-0.5.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Primitive memory-related operations"
HOMEPAGE="http://code.haskell.org/primitive"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/primitive/primitive-0.5.1.0.ebuild b/dev-haskell/primitive/primitive-0.5.1.0.ebuild
index 881eaad3cf67..33227f2d42f0 100644
--- a/dev-haskell/primitive/primitive-0.5.1.0.ebuild
+++ b/dev-haskell/primitive/primitive-0.5.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Primitive memory-related operations"
HOMEPAGE="https://github.com/haskell/primitive"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/primitive/primitive-0.5.4.0.ebuild b/dev-haskell/primitive/primitive-0.5.4.0.ebuild
index 4eee8e0ed71c..486b5e9c622d 100644
--- a/dev-haskell/primitive/primitive-0.5.4.0.ebuild
+++ b/dev-haskell/primitive/primitive-0.5.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Primitive memory-related operations"
HOMEPAGE="https://github.com/haskell/primitive"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/primitive/primitive-0.6.1.0-r1.ebuild b/dev-haskell/primitive/primitive-0.6.1.0-r1.ebuild
index eb41ccc7b540..15f99fe4cf42 100644
--- a/dev-haskell/primitive/primitive-0.6.1.0-r1.ebuild
+++ b/dev-haskell/primitive/primitive-0.6.1.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Primitive memory-related operations"
HOMEPAGE="https://github.com/haskell/primitive"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"