summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:05:01 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:08:59 +0100
commitf55b5f478f7b4aca2f8f0aeb451f9a8657743620 (patch)
tree8f203da031efc16a689c3b9ae407e868f148d7d1 /dev-haskell/skylighting
parentdev-haskell/skylighting-format-latex: new package, add 0.1 (diff)
downloadgentoo-f55b5f478f7b4aca2f8f0aeb451f9a8657743620.tar.gz
gentoo-f55b5f478f7b4aca2f8f0aeb451f9a8657743620.tar.bz2
gentoo-f55b5f478f7b4aca2f8f0aeb451f9a8657743620.zip
dev-haskell/skylighting: add 0.14
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/skylighting')
-rw-r--r--dev-haskell/skylighting/Manifest1
-rw-r--r--dev-haskell/skylighting/metadata.xml1
-rw-r--r--dev-haskell/skylighting/skylighting-0.14.ebuild39
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/skylighting/Manifest b/dev-haskell/skylighting/Manifest
index 5cc5a60adb30..feed0d11c934 100644
--- a/dev-haskell/skylighting/Manifest
+++ b/dev-haskell/skylighting/Manifest
@@ -1 +1,2 @@
DIST skylighting-0.12.3.1.tar.gz 1218260 BLAKE2B 78f26d3477a6327a8e3c99f31ffe3c1d1b57c86730c06f715d8b2db9d267526bf3d0605639679fc38e4faff06e81edc3d2c9d85e7ce3c557b73f47ae8e81b999 SHA512 3eb93400612992d5aed828ebe0c1b76dbfbd7ec9cd0d0d667b524df51968997ffd429bfdbecbaa32a6108903872e119614b16f8aedf00eaf6d9a7b79ccb06c58
+DIST skylighting-0.14.tar.gz 1393626 BLAKE2B 884f990b77d38c71287486ec0c2d652bf408a21878b11cac071053616b78ea759e83cd8f4c54befdffb2d4b32dbd352e2adc5db20bfacb1209866e1992c645b1 SHA512 33d36f7181c0a6b94d3319707d6ea68199239a7699c18c6392e8ae49d97d7249f57f4d42a9fb09fa9df643268aa57b8e42e2204a6a002f8222ef00284dfd25d4
diff --git a/dev-haskell/skylighting/metadata.xml b/dev-haskell/skylighting/metadata.xml
index 05c0818ed2d1..e4e3cb3a2ce1 100644
--- a/dev-haskell/skylighting/metadata.xml
+++ b/dev-haskell/skylighting/metadata.xml
@@ -19,6 +19,7 @@
highlighting-kate.
</longdescription>
<upstream>
+ <remote-id type="hackage">skylighting</remote-id>
<remote-id type="github">jgm/skylighting</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/skylighting/skylighting-0.14.ebuild b/dev-haskell/skylighting/skylighting-0.14.ebuild
new file mode 100644
index 000000000000..a7b302f95c3b
--- /dev/null
+++ b/dev-haskell/skylighting/skylighting-0.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: -bootstrap,+system-pcre
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="syntax highlighting library"
+HOMEPAGE="https://github.com/jgm/skylighting"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="executable"
+
+RDEPEND="~dev-haskell/skylighting-core-0.14:=[profile?]
+ >=dev-haskell/skylighting-format-ansi-0.1:=[profile?] <dev-haskell/skylighting-format-ansi-0.2:=[profile?]
+ >=dev-haskell/skylighting-format-blaze-html-0.1:=[profile?] <dev-haskell/skylighting-format-blaze-html-0.2:=[profile?]
+ >=dev-haskell/skylighting-format-context-0.1:=[profile?] <dev-haskell/skylighting-format-context-0.2:=[profile?]
+ >=dev-haskell/skylighting-format-latex-0.1:=[profile?] <dev-haskell/skylighting-format-latex-0.2:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+ executable? ( >=dev-haskell/blaze-html-0.5:=[profile?]
+ dev-haskell/pretty-show:=[profile?]
+ dev-haskell/text:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bootstrap \
+ $(cabal_flag executable executable) \
+ --flag=system-pcre
+}