summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-09-04 16:59:42 +1200
committerKent Fredric <kentnl@gentoo.org>2016-09-04 17:01:44 +1200
commite0631bd3e5aa6d45efcfec8f2d2ce9199fdd9e6c (patch)
tree2d02a8947e8b447531d6d8d8ba22098669f9c11d /dev-java/boot-bin/boot-bin-2.6.0.ebuild
parentapp-crypt/certbot: psutil IS required... (diff)
downloadgentoo-e0631bd3e5aa6d45efcfec8f2d2ce9199fdd9e6c.tar.gz
gentoo-e0631bd3e5aa6d45efcfec8f2d2ce9199fdd9e6c.tar.bz2
gentoo-e0631bd3e5aa6d45efcfec8f2d2ce9199fdd9e6c.zip
dev-java/boot-bin: Added at 2.6.0
This is mostly just giving users a better choice than "sudo bash curl..." boot will still have to install its own dependencies when executed via maven glue into ~/.m2/, but this still means they can easily get `boot` accessible globally in "$PATH" without security paranoia, and from then on it "mostly just works" without needing to understand boot-specific install procedures. Ideally this itself will be built from sources one day, but java upstream logic fights this at every stage. Also, "boot -u" still does "something", but it doesn't do anything useful. Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-java/boot-bin/boot-bin-2.6.0.ebuild')
-rw-r--r--dev-java/boot-bin/boot-bin-2.6.0.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-java/boot-bin/boot-bin-2.6.0.ebuild b/dev-java/boot-bin/boot-bin-2.6.0.ebuild
new file mode 100644
index 000000000000..8bf39a4268e2
--- /dev/null
+++ b/dev-java/boot-bin/boot-bin-2.6.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit java-pkg-2
+
+MY_PN="${PN%-bin}"
+MY_PNV="${MY_PN}-${PV}"
+
+DESCRIPTION="Build tooling for Clojure"
+HOMEPAGE="http://boot-clj.com/"
+SRC_URI="https://github.com/boot-clj/${MY_PN}/releases/download/${PV}/${MY_PN}.jar -> ${MY_PNV}.jar"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jdk-1.7:*"
+DEPEND=">=virtual/jdk-1.7:*"
+
+RESTRICT="test"
+
+src_unpack() {
+ mkdir -p "${S}" || die "Can't mkdir ${S}"
+ cd "${S}" || die "Can't enter ${S}"
+ for file in ${A}; do
+ einfo "Copying ${file}"
+ cp "${DISTDIR}/${file}" "${S}/" || die "Can't copy ${file}"
+ done
+}
+
+src_prepare() {
+ einfo "Copying boot shell-script"
+ cp "${FILESDIR}/boot" "${S}/" || die "Can't copy boot"
+
+ java-pkg_init_paths_
+
+ sed -i "s|@@JAVA_PKG_SHAREPATH@@|${JAVA_PKG_SHAREPATH}|g" "${S}/boot" || die "Can't patch JAVA_PKG_SHAREPATH path in boot"
+ sed -i "s|@@JAVA_PKG_JARDEST@@|${JAVA_PKG_JARDEST}|g" "${S}/boot" || die "Can't patch JAVA_PKG_JARDEST path in boot"
+ sed -i "s|@@PN@@|${PN}|g" "${S}/boot" || die "Can't patch PN in boot"
+
+ default
+}
+
+src_compile() { :; }
+
+src_install() {
+ dobin "${S}/boot"
+ java-pkg_newjar "${S}/${MY_PNV}.jar"
+}
+
+pkg_postinst() {
+ einfo "This package will still download a whole lot of its own runtime"
+ einfo "dependencies the first time you run it."
+ einfo ""
+ einfo "This currently can't be helped and is expected behaviour for a"
+ einfo "java based development toolkit"
+}