summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-logging/commons-logging-1.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-logging/commons-logging-1.2.ebuild')
-rw-r--r--dev-java/commons-logging/commons-logging-1.2.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/dev-java/commons-logging/commons-logging-1.2.ebuild b/dev-java/commons-logging/commons-logging-1.2.ebuild
new file mode 100644
index 000000000000..e1edb14bb5de
--- /dev/null
+++ b/dev-java/commons-logging/commons-logging-1.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2 java-osgi
+
+DESCRIPTION="The Jakarta-Commons Logging package is an ultra-thin bridge between different logging libraries"
+HOMEPAGE="http://commons.apache.org/logging/"
+SRC_URI="mirror://apache/commons/logging/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="avalon-logkit log4j servletapi avalon-framework"
+
+COMMON_DEP="
+ avalon-logkit? ( dev-java/avalon-logkit:1.2 )
+ log4j? ( dev-java/log4j:0 )
+ servletapi? ( java-virtuals/servlet-api:2.3 )
+ avalon-framework? ( dev-java/avalon-framework:4.2 )"
+# ATTENTION: Add this when log4j-1.3 is out
+# =dev-java/log4j-1.3*
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.6
+ ${COMMON_DEP}
+ test? ( dev-java/ant-junit:0 )"
+
+S="${WORKDIR}/${P}-src/"
+
+RESTRICT="!servletapi? ( test )"
+
+java_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ # patch to make the build.xml respect no servletapi
+ # TODO file upstream -nichoj
+ epatch "${FILESDIR}/${P}-servletapi.patch"
+
+ # bug 200918
+ java-ant_ignore-system-classes
+
+ # bug #208098
+ echo "jdk.1.4.present=true" > build.properties
+ use log4j && echo "log4j12.jar=$(java-pkg_getjars log4j)" >> build.properties
+ # ATTENTION: Add this when log4j-1.3 is out (check the SLOT)
+ #echo "log4j13.jar=$(java-pkg_getjars log4j-1.3)" > build.properties
+ use avalon-logkit && echo "logkit.jar=$(java-pkg_getjars avalon-logkit-1.2)" >> build.properties
+ use servletapi && echo "servletapi.jar=$(java-pkg_getjar --virtual servlet-api-2.3 servlet.jar)" >> build.properties
+ use avalon-framework && echo "avalon-framework.jar=$(java-pkg_getjars avalon-framework-4.2)" >> build.properties
+ java-pkg_filter-compiler jikes ecj-3.2
+
+ if use test && ! use servletapi; then
+ eerror "Tests need use servletapi, tests not executed"
+ fi
+}
+
+EANT_BUILD_TARGET="compile"
+
+src_install() {
+ java-osgi_newjar "target/${P}.jar" "org.apache.commons.logging" "Apache Commons Logging" "org.apache.commons.logging;version=\"${PV}\", org.apache.commons.logging.impl;version=\"${PV}\""
+ java-pkg_newjar target/${PN}-api-${PV}.jar ${PN}-api.jar
+ java-pkg_newjar target/${PN}-adapters-${PV}.jar ${PN}-adapters.jar
+
+ dodoc RELEASE-NOTES.txt || die
+ dohtml PROPOSAL.html || die
+ use doc && java-pkg_dojavadoc target/docs/
+ use source && java-pkg_dosrc src/main/java/org
+}