summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-06-24 13:23:28 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-06-28 17:52:07 +0200
commit5b2fa22e5ffabe7b2e6c457307cd4b653ddb33e7 (patch)
treede8df50dcf870dffab4391c0937eb3c51d424d71 /dev-java/jakarta-activation-api/jakarta-activation-api-1.2.2.ebuild
parentprofiles: unamask dist-kernel use on amd64 (diff)
downloadgentoo-5b2fa22e5ffabe7b2e6c457307cd4b653ddb33e7.tar.gz
gentoo-5b2fa22e5ffabe7b2e6c457307cd4b653ddb33e7.tar.bz2
gentoo-5b2fa22e5ffabe7b2e6c457307cd4b653ddb33e7.zip
dev-java/jakarta-activation-api: version 1.2.2
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/21319/commits/63fc3220249300d81201795b89f753a50f6483a8 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/jakarta-activation-api/jakarta-activation-api-1.2.2.ebuild')
-rw-r--r--dev-java/jakarta-activation-api/jakarta-activation-api-1.2.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-java/jakarta-activation-api/jakarta-activation-api-1.2.2.ebuild b/dev-java/jakarta-activation-api/jakarta-activation-api-1.2.2.ebuild
new file mode 100644
index 000000000000..d66cea7f3dd0
--- /dev/null
+++ b/dev-java/jakarta-activation-api/jakarta-activation-api-1.2.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom jaf-1.2.2/activationapi/pom.xml --download-uri https://github.com/eclipse-ee4j/jaf/archive/refs/tags/1.2.2.tar.gz --slot 1 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild jakarta-activation-api-1.2.2.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="jakarta.activation:jakarta.activation-api:1.2.2"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Jakarta Activation API jar"
+HOMEPAGE="https://eclipse-ee4j.github.io/jaf/"
+SRC_URI="https://github.com/eclipse-ee4j/jaf/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+BDEPEND="app-arch/zip"
+
+DOCS=( ../{CONTRIBUTING,LICENSE,NOTICE,README}.md )
+
+S="${WORKDIR}/jaf-${PV}/activation"
+
+JAVA_ENCODING="iso-8859-1"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_RESOURCE_DIRS="src/main/resources"
+
+src_prepare() {
+ default
+ # these files are not present in the upstream jar
+ find ${JAVA_RESOURCE_DIRS} -name "*.default" -delete || die "Failed to delete *.default files"
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ # we remove implementation classes from the api
+ zip -d ${PN}.jar "com/*" || die "Failed to remove implementation classes"
+}
+
+src_install() {
+ default
+ # we remove the implementation sources so that they don't land in sources
+ rm -fr ${JAVA_SRC_DIR}/com || "Failed to delete implementation sources"
+ java-pkg-simple_src_install
+}