summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/java-sdk-docs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/java-sdk-docs')
-rw-r--r--dev-java/java-sdk-docs/Manifest3
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.6.0.30.ebuild46
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.7.0.80.ebuild49
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.8.0.51.ebuild49
-rw-r--r--dev-java/java-sdk-docs/metadata.xml5
5 files changed, 152 insertions, 0 deletions
diff --git a/dev-java/java-sdk-docs/Manifest b/dev-java/java-sdk-docs/Manifest
new file mode 100644
index 000000000000..82724982be41
--- /dev/null
+++ b/dev-java/java-sdk-docs/Manifest
@@ -0,0 +1,3 @@
+DIST jdk-6u30-apidocs.zip 59086542 SHA256 92739c56e02fa6e7ac8d60a1f59a0ef4a59ac99ab2979d3cdc495bfecf1a50ab SHA512 5139b1a65765f258f21c629a0cfbf07aed0c12b3eb08d4615b049e825abd90c5b3385af99dba3a4ac6e0a94a5ffaa32ee648fb3e7ac1815ec6b74fe0d8e9f0ee WHIRLPOOL 941236c68b189f9cd23f0e904cc01da9f87cc39967c84cddf4c20a04fa2872eb99af147a21bb770320cad28b2cd86205402a141f7217d5301fa9a6ea41c3a136
+DIST jdk-7u80-docs-all.zip 61168809 SHA256 0494bd49bc9cb3cbe3203120ae8b2c8e0aeb1579cb15c0fbd3cd780d19aa200a SHA512 c673c00e55c9a19938c42512cb9c6ae65de9803a1307d11a2043903d87cc36d9ed1f5a1e287040d8570e430cfe55f496354c1242fe6e242f1245f8271394ea1a WHIRLPOOL ad18886c401ec42735665081a0dd5ba3dc7678de0171f3aa8151c2e4ce3392e467be65c602f393da38373e589fa9800ed1afd3601d2cef4e48b06e57f491698e
+DIST jdk-8u51-docs-all.zip 92230995 SHA256 fa36f0611df525b39e27353daa42b089dc76f86f7dc09b0dc98d72c10ba76284 SHA512 bb1e65820902153d2fbebc170b18bce0c630dc8b5ce70fde53f6b55f9203267411846b9c81a77fb0c45f30df30f4d327120499c3ad11dc8e50c078d096e1943f WHIRLPOOL dd0e6b2dfbd8ce9960359013ace595c50c7281e8bed3e7cbc2a93f6a776eb4d60ecbc7d2a16796eefca02d38af3fcee9b4633215288ce464fed852e147599a50
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.6.0.30.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.6.0.30.ebuild
new file mode 100644
index 000000000000..9b0ee7a4f926
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.6.0.30.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit versionator
+
+UPDATE_VER="$(get_version_component_range 4)"
+
+SRC_URI="jdk-6u${UPDATE_VER}-apidocs.zip"
+DESCRIPTION="Sun's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/6/docs/index.html"
+LICENSE="oracle-java-documentation"
+SLOT="1.6.0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND=""
+RESTRICT="fetch"
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/downloads/jdk-6u25-doc-download-355137.html"
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${SRC_URI} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(yes, the download page URL refers to an older version for some reason)"
+ einfo "(agree to the license) and place it in ${DISTDIR}"
+
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report to the bug 67266 (link below)."
+ einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "http://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins index.html
+
+ for i in *; do
+ [[ -d $i ]] && doins -r $i
+ done
+}
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.80.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.80.ebuild
new file mode 100644
index 000000000000..52215cf52664
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.80.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit versionator
+
+MY_PV="$(get_version_component_range 2)u$(get_version_component_range 4)"
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/java-se-7-doc-download-435117.html#jdk-${MY_PV}-apidocs-oth-JPR"
+ORIG_NAME="jdk-${MY_PV}-docs-all.zip"
+
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/7/docs/"
+SRC_URI="${ORIG_NAME}"
+
+LICENSE="oracle-java-documentation-7"
+SLOT="1.7"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${ORIG_NAME} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(agree to the license) and place it in ${DISTDIR}"
+
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report to the bug 67266 (link below)."
+ einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "http://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins index.html
+
+ for i in *; do
+ [[ -d $i ]] && doins -r $i
+ done
+}
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.51.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.51.ebuild
new file mode 100644
index 000000000000..f97746c7d467
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.51.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit versionator
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/jdk8-doc-downloads-2133158.html"
+
+[[ "$(get_version_component_range 4)" == 0 ]] \
+ || MY_PV_EXT="u$(get_version_component_range 4)"
+
+MY_PV="$(get_version_component_range 2)${MY_PV_EXT}"
+ORIG_NAME="jdk-${MY_PV}-docs-all.zip"
+
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/8/docs/"
+SRC_URI="${ORIG_NAME}"
+LICENSE="oracle-java-documentation-8"
+SLOT="1.8"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+RESTRICT="fetch"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${ORIG_NAME} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(agree to the license) and place it in ${DISTDIR}"
+
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report to the bug 67266 (link below)."
+ einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "http://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins index.html
+
+ for i in *; do
+ [[ -d $i ]] && doins -r $i
+ done
+}
diff --git a/dev-java/java-sdk-docs/metadata.xml b/dev-java/java-sdk-docs/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/java-sdk-docs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>