summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jcs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jcs')
-rw-r--r--dev-java/jcs/Manifest1
-rw-r--r--dev-java/jcs/files/build-1.2.7.8.xml40
-rw-r--r--dev-java/jcs/files/build-1.2.7.9.xml40
-rw-r--r--dev-java/jcs/files/build-1.3.xml38
-rw-r--r--dev-java/jcs/files/jcs-2.0-build.xml306
-rw-r--r--dev-java/jcs/jcs-2.0.ebuild97
-rw-r--r--dev-java/jcs/metadata.xml8
7 files changed, 530 insertions, 0 deletions
diff --git a/dev-java/jcs/Manifest b/dev-java/jcs/Manifest
new file mode 100644
index 000000000000..80846b57bf12
--- /dev/null
+++ b/dev-java/jcs/Manifest
@@ -0,0 +1 @@
+DIST commons-jcs-dist-2.0-beta-1-src.tar.gz 825048 SHA256 2ff60facc31b52625f1f2d8907380947508790bd864e2fea03625dee0c36ffa5 SHA512 56d68807de6d47debc893584a738bc797c2a150503ae460dc1444e9434b438926f6ad9fe8c1292250f6a0b2936210084cbd512083b5a8cc4f20e692b759a314f WHIRLPOOL e5e67465a7c318ec73de3ffacc566cce48304a3379885dd814f0c32f362c1d2e24abf2935e090056df0bd8db0fa85cb36553203e5eb6e837e23e888ca6cd137f
diff --git a/dev-java/jcs/files/build-1.2.7.8.xml b/dev-java/jcs/files/build-1.2.7.8.xml
new file mode 100644
index 000000000000..f3623a42de76
--- /dev/null
+++ b/dev-java/jcs/files/build-1.2.7.8.xml
@@ -0,0 +1,40 @@
+<?xml version="1.0" encoding="utf-8"?>
+<project name="Gentoo_Builder" default="jar" basedir=".">
+ <property name="src" value="src/java"/>
+ <property name="build" value="build"/>
+ <property name="dist" value="dist"/>
+ <property name="pkg" value="${package.name}"/>
+ <property name="jar" value="${project.name}.jar"/>
+ <property file="build.properties"/>
+ <target name="init">
+ <tstamp/>
+ <mkdir dir="${build}"/>
+ <mkdir dir="${dist}"/>
+ <mkdir dir="${dist}/doc"/>
+ </target>
+ <target name="compile" depends="init">
+ <javac srcdir="${src}" destdir="${build}" classpath="${classpath}"/>
+ </target>
+ <target name="manifest" depends="init">
+ <manifest file="${build}/MANIFEST.MF" mode="update">
+ <attribute name="Built-By" value="Gentoo Portage"/>
+ </manifest>
+ </target>
+ <target name="jar" depends="compile,manifest">
+ <jar jarfile="${dist}/${jar}" manifest="${build}/MANIFEST.MF">
+ <fileset dir="${build}"/>
+ <fileset dir="${src}">
+ <include name="**/*.vm"/>
+ </fileset>
+ </jar>
+ </target>
+ <target name="javadoc" depends="compile">
+ <javadoc destdir="${dist}/doc/api">
+ <fileset dir="${src}"/>
+ </javadoc>
+ </target>
+ <target name="clean">
+ <delete dir="${build}"/>
+ <delete dir="${dist}"/>
+ </target>
+</project>
diff --git a/dev-java/jcs/files/build-1.2.7.9.xml b/dev-java/jcs/files/build-1.2.7.9.xml
new file mode 100644
index 000000000000..f3623a42de76
--- /dev/null
+++ b/dev-java/jcs/files/build-1.2.7.9.xml
@@ -0,0 +1,40 @@
+<?xml version="1.0" encoding="utf-8"?>
+<project name="Gentoo_Builder" default="jar" basedir=".">
+ <property name="src" value="src/java"/>
+ <property name="build" value="build"/>
+ <property name="dist" value="dist"/>
+ <property name="pkg" value="${package.name}"/>
+ <property name="jar" value="${project.name}.jar"/>
+ <property file="build.properties"/>
+ <target name="init">
+ <tstamp/>
+ <mkdir dir="${build}"/>
+ <mkdir dir="${dist}"/>
+ <mkdir dir="${dist}/doc"/>
+ </target>
+ <target name="compile" depends="init">
+ <javac srcdir="${src}" destdir="${build}" classpath="${classpath}"/>
+ </target>
+ <target name="manifest" depends="init">
+ <manifest file="${build}/MANIFEST.MF" mode="update">
+ <attribute name="Built-By" value="Gentoo Portage"/>
+ </manifest>
+ </target>
+ <target name="jar" depends="compile,manifest">
+ <jar jarfile="${dist}/${jar}" manifest="${build}/MANIFEST.MF">
+ <fileset dir="${build}"/>
+ <fileset dir="${src}">
+ <include name="**/*.vm"/>
+ </fileset>
+ </jar>
+ </target>
+ <target name="javadoc" depends="compile">
+ <javadoc destdir="${dist}/doc/api">
+ <fileset dir="${src}"/>
+ </javadoc>
+ </target>
+ <target name="clean">
+ <delete dir="${build}"/>
+ <delete dir="${dist}"/>
+ </target>
+</project>
diff --git a/dev-java/jcs/files/build-1.3.xml b/dev-java/jcs/files/build-1.3.xml
new file mode 100644
index 000000000000..c7b94bf6371c
--- /dev/null
+++ b/dev-java/jcs/files/build-1.3.xml
@@ -0,0 +1,38 @@
+<?xml version="1.0" encoding="utf-8"?>
+<project name="Gentoo_Builder" default="jar" basedir=".">
+ <property name="src" value="src/java"/>
+ <property name="build" value="build"/>
+ <property name="dist" value="dist"/>
+ <property name="pkg" value="${package.name}"/>
+ <property name="jar" value="${project.name}.jar"/>
+ <property file="build.properties"/>
+ <target name="init">
+ <tstamp/>
+ <mkdir dir="${build}"/>
+ <mkdir dir="${dist}"/>
+ <mkdir dir="${dist}/doc"/>
+ </target>
+ <target name="compile" depends="init">
+ <javac srcdir="${src}" destdir="${build}" classpath="${classpath}"/>
+ </target>
+ <target name="manifest" depends="init">
+ <manifest file="${build}/MANIFEST.MF" mode="update">
+ <attribute name="Built-By" value="Gentoo Portage"/>
+ </manifest>
+ </target>
+ <target name="jar" depends="compile,manifest">
+ <jar jarfile="${dist}/${jar}" manifest="${build}/MANIFEST.MF">
+ <fileset dir="${build}"/>
+ <fileset dir="${src}">
+ <include name="**/*.vm"/>
+ </fileset>
+ </jar>
+ </target>
+ <target name="javadoc" depends="compile">
+ <javadoc destdir="${dist}/doc/api" sourcepath="${src}" />
+ </target>
+ <target name="clean">
+ <delete dir="${build}"/>
+ <delete dir="${dist}"/>
+ </target>
+</project>
diff --git a/dev-java/jcs/files/jcs-2.0-build.xml b/dev-java/jcs/files/jcs-2.0-build.xml
new file mode 100644
index 000000000000..04c4dae81729
--- /dev/null
+++ b/dev-java/jcs/files/jcs-2.0-build.xml
@@ -0,0 +1,306 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 6/14/15 12:02 AM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="commons-jcs-core-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="commons-jcs-core-2.0-beta-1"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/test-conf"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/commons-logging/commons-logging/1.2/commons-logging-1.2.jar"/>
+ <pathelement location="${maven.repo.local}/commons-dbcp/commons-dbcp/1.4/commons-dbcp-1.4.jar"/>
+ <pathelement location="${maven.repo.local}/commons-pool/commons-pool/1.6/commons-pool-1.6.jar"/>
+ <pathelement location="${maven.repo.local}/hsqldb/hsqldb/1.8.0.10/hsqldb-1.8.0.10.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/velocity/velocity-tools/2.0/velocity-tools-2.0.jar"/>
+ <pathelement location="${maven.repo.local}/commons-beanutils/commons-beanutils/1.7.0/commons-beanutils-1.7.0.jar"/>
+ <pathelement location="${maven.repo.local}/commons-digester/commons-digester/1.8/commons-digester-1.8.jar"/>
+ <pathelement location="${maven.repo.local}/commons-chain/commons-chain/1.1/commons-chain-1.1.jar"/>
+ <pathelement location="${maven.repo.local}/commons-collections/commons-collections/3.2/commons-collections-3.2.jar"/>
+ <pathelement location="${maven.repo.local}/commons-validator/commons-validator/1.3.1/commons-validator-1.3.1.jar"/>
+ <pathelement location="${maven.repo.local}/dom4j/dom4j/1.1/dom4j-1.1.jar"/>
+ <pathelement location="${maven.repo.local}/oro/oro/2.0.8/oro-2.0.8.jar"/>
+ <pathelement location="${maven.repo.local}/sslext/sslext/1.2-0/sslext-1.2-0.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/struts/struts-core/1.3.8/struts-core-1.3.8.jar"/>
+ <pathelement location="${maven.repo.local}/antlr/antlr/2.7.2/antlr-2.7.2.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/struts/struts-taglib/1.3.8/struts-taglib-1.3.8.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/struts/struts-tiles/1.3.8/struts-tiles-1.3.8.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/velocity/velocity/1.6.2/velocity-1.6.2.jar"/>
+ <pathelement location="${maven.repo.local}/commons-lang/commons-lang/2.4/commons-lang-2.4.jar"/>
+ <pathelement location="${maven.repo.local}/commons-httpclient/commons-httpclient/3.1/commons-httpclient-3.1.jar"/>
+ <pathelement location="${maven.repo.local}/commons-codec/commons-codec/1.2/commons-codec-1.2.jar"/>
+ <pathelement location="${maven.repo.local}/javax/servlet/servlet-api/2.5/servlet-api-2.5.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/commons-logging/commons-logging/1.2/commons-logging-1.2.jar"/>
+ <pathelement location="${maven.repo.local}/commons-dbcp/commons-dbcp/1.4/commons-dbcp-1.4.jar"/>
+ <pathelement location="${maven.repo.local}/commons-pool/commons-pool/1.6/commons-pool-1.6.jar"/>
+ <pathelement location="${maven.repo.local}/hsqldb/hsqldb/1.8.0.10/hsqldb-1.8.0.10.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/commons/commons-collections4/4.0/commons-collections4-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit/4.11/junit-4.11.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-library/1.3/hamcrest-library-1.3.jar"/>
+ <pathelement location="${maven.repo.local}/log4j/log4j/1.2.17/log4j-1.2.17.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/velocity/velocity-tools/2.0/velocity-tools-2.0.jar"/>
+ <pathelement location="${maven.repo.local}/commons-beanutils/commons-beanutils/1.7.0/commons-beanutils-1.7.0.jar"/>
+ <pathelement location="${maven.repo.local}/commons-digester/commons-digester/1.8/commons-digester-1.8.jar"/>
+ <pathelement location="${maven.repo.local}/commons-chain/commons-chain/1.1/commons-chain-1.1.jar"/>
+ <pathelement location="${maven.repo.local}/commons-collections/commons-collections/3.2/commons-collections-3.2.jar"/>
+ <pathelement location="${maven.repo.local}/commons-validator/commons-validator/1.3.1/commons-validator-1.3.1.jar"/>
+ <pathelement location="${maven.repo.local}/dom4j/dom4j/1.1/dom4j-1.1.jar"/>
+ <pathelement location="${maven.repo.local}/oro/oro/2.0.8/oro-2.0.8.jar"/>
+ <pathelement location="${maven.repo.local}/sslext/sslext/1.2-0/sslext-1.2-0.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/struts/struts-core/1.3.8/struts-core-1.3.8.jar"/>
+ <pathelement location="${maven.repo.local}/antlr/antlr/2.7.2/antlr-2.7.2.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/struts/struts-taglib/1.3.8/struts-taglib-1.3.8.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/struts/struts-tiles/1.3.8/struts-tiles-1.3.8.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/velocity/velocity/1.6.2/velocity-1.6.2.jar"/>
+ <pathelement location="${maven.repo.local}/commons-lang/commons-lang/2.4/commons-lang-2.4.jar"/>
+ <pathelement location="${maven.repo.local}/commons-httpclient/commons-httpclient/3.1/commons-httpclient-3.1.jar"/>
+ <pathelement location="${maven.repo.local}/commons-codec/commons-codec/1.2/commons-codec-1.2.jar"/>
+ <pathelement location="${maven.repo.local}/javax/servlet/servlet-api/2.5/servlet-api-2.5.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <mkdir dir="${maven.build.outputDir}//var/tmp/portage/dev-java/jcs-2.0/work/commons-jcs-dist-2.0-beta-1-src/commons-jcs-core/target/classes"/>
+ <copy todir="${maven.build.outputDir}//var/tmp/portage/dev-java/jcs-2.0/work/commons-jcs-dist-2.0-beta-1-src/commons-jcs-core/target/classes">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}">
+ <include name="**/*.properties"/>
+ <include name="**/*.ccf"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/*UnitTest.java"/>
+ <exclude name="**/BlockDiskElementDescriptorUnitTest.java"/>
+ <exclude name="**/HSQLDiskCacheConcurrentUnitTest.java"/>
+ <exclude name="**/HSQLDiskCacheUnitTest.java"/>
+ <exclude name="**/IndexedDiskCacheOptimizationUnitTest.java"/>
+ <exclude name="**/TestTCPLateralUnitTest.java"/>
+ <exclude name="**/UDPDiscoveryUnitTest.java"/>
+ <exclude name="**/UDPDiscoverySenderUnitTest.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/BlockDiskElementDescriptorUnitTest.java"/>
+ <exclude name="**/HSQLDiskCacheConcurrentUnitTest.java"/>
+ <exclude name="**/HSQLDiskCacheUnitTest.java"/>
+ <exclude name="**/IndexedDiskCacheOptimizationUnitTest.java"/>
+ <exclude name="**/TestTCPLateralUnitTest.java"/>
+ <exclude name="**/UDPDiscoveryUnitTest.java"/>
+ <exclude name="**/UDPDiscoverySenderUnitTest.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present" classpathref="build.test.classpath"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in the test classpath or your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="UTF-8"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ docencoding="UTF-8"
+ source="1.6"
+ linksource="true"
+ breakiterator="false">
+ <link href="http://docs.oracle.com/javase/6/docs/api/"/>
+ <link href="http://docs.oracle.com/javaee/6/api/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ <manifest>
+ <attribute name="Main-Class" value="Main"/>
+ </manifest>
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+</project>
diff --git a/dev-java/jcs/jcs-2.0.ebuild b/dev-java/jcs/jcs-2.0.ebuild
new file mode 100644
index 000000000000..e31677d17053
--- /dev/null
+++ b/dev-java/jcs/jcs-2.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="test doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="commons-${PN}-dist-${PV}-beta-1-src"
+JCS_CORE="commons-${PN}-core"
+
+DESCRIPTION="JCS is a distributed caching system written in Java for server-side Java applications"
+HOMEPAGE="http://commons.apache.org/jcs/"
+SRC_URI="http://apache.mirrors.ovh.net/ftp.apache.org/dist/commons/${PN}/source/commons-${PN}-dist-${PV}-beta-1-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2.0"
+KEYWORDS="amd64 ppc x86"
+IUSE="admin"
+
+CDEPEND="dev-java/jisp:2.5
+ dev-db/hsqldb:0
+ dev-java/log4j:0
+ dev-java/xmlrpc:3
+ dev-java/commons-lang:0
+ dev-java/commons-dbcp:0
+ dev-java/commons-pool:0
+ dev-java/commons-logging:0
+ dev-java/commons-httpclient:3
+ java-virtuals/servlet-api:3.0"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.6
+ test? ( dev-java/ant-junit:0 )
+ ${CDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="
+ xmlrpc-3
+ hsqldb
+ jisp-2.5
+ log4j
+ commons-lang
+ commons-pool
+ commons-dbcp
+ commons-logging
+ commons-httpclient-3
+ servlet-api-3.0
+"
+
+EANT_BUILD_XML="${JCS_CORE}/build.xml"
+EANT_BUILD_TARGET="package"
+
+java_prepare() {
+ cp "${FILESDIR}/${P}-build.xml" ${JCS_CORE}/build.xml
+
+ # Disable the velocity-tools dep.
+ rm -v \
+ ${JCS_CORE}/src/main/java/org/apache/commons/jcs/admin/servlet/JCSAdminServlet.java
+
+ if use test; then
+ # Make use of commons-collections4 not yet packaged in Gentoo
+ rm -v \
+ "${JCS_CORE}"/src/test/java/org/apache/commons/jcs/utils/struct/JCSvsCommonsLRUMapPerformanceTest.java \
+ "${JCS_CORE}"/src/test/java/org/apache/commons/jcs/utils/struct/LRUMapPerformanceTest.java
+
+ # Fails for some reason.
+ rm -v \
+ "${JCS_CORE}"/src/test/java/org/apache/commons/jcs/auxiliary/disk/AbstractDiskCacheUnitTest.java \
+ "${JCS_CORE}"/src/test/java/org/apache/commons/jcs/auxiliary/disk/LRUMapJCSUnitTest.java \
+ "${JCS_CORE}"/src/test/java/org/apache/commons/jcs/engine/logging/CacheEventLoggerDebugLoggerUnitTest.java \
+ "${JCS_CORE}"/src/test/java/org/apache/commons/jcs/utils/struct/DoubleLinkedListUnitTest.java
+ fi
+}
+
+EANT_TEST_TARGET="test"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ local target="${JCS_CORE}"/target
+ java-pkg_newjar "${target}"/"${JCS_CORE}-${PV}"-beta-1.jar "${JCS_CORE}".jar
+
+ if use doc; then
+ java-pkg_dojavadoc "${target}"/site/apidocs
+ fi
+
+ if use source; then
+ java-pkg_dosrc "${JCS_CORE}"/src
+ fi
+}
diff --git a/dev-java/jcs/metadata.xml b/dev-java/jcs/metadata.xml
new file mode 100644
index 000000000000..106955320fec
--- /dev/null
+++ b/dev-java/jcs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <use>
+ <flag name="admin">Enable JCS Admin servlets</flag>
+ </use>
+</pkgmetadata>