summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jzlib/jzlib-1.1.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jzlib/jzlib-1.1.1.ebuild')
-rw-r--r--dev-java/jzlib/jzlib-1.1.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-java/jzlib/jzlib-1.1.1.ebuild b/dev-java/jzlib/jzlib-1.1.1.ebuild
new file mode 100644
index 000000000000..5151533e9593
--- /dev/null
+++ b/dev-java/jzlib/jzlib-1.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="JZlib is a re-implementation of zlib in pure Java"
+HOMEPAGE="http://www.jcraft.com/jzlib/"
+SRC_URI="http://www.jcraft.com/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="1.1"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.5"
+DEPEND="
+ >=virtual/jdk-1.5"
+# test? (
+# dev-lang/scala
+# dev-java/junit:4 )"
+# Restrict test due to missing keywords for scala
+RESTRICT="test"
+
+S="${WORKDIR}/${P}"
+JAVA_SRC_DIR="src/main/java"
+
+java_prepare() {
+ # Maven not yet supported, use java-pkg-simple instead.
+ rm -v pom.xml || die
+}
+
+src_test() {
+ local CP TESTS
+ CP="${PN}.jar:$(java-pkg_getjars --with-dependencies scala,junit-4)" || die
+ TESTS=$(find src/test/scala -name '*Test.scala' -printf com.jcraft.jzlib. -exec basename {} .scala \;) || die
+
+ mkdir -p target/test || die
+ find src/test/scala -name '*.scala' -exec scalac -classpath "${CP}" -d target/test {} + || die
+ ejunit4 -classpath "target/test:${CP}" ${TESTS}
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc README ChangeLog
+ use examples && java-pkg_doexamples example
+}