summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-06-18 19:28:13 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-07-07 09:04:16 +0200
commitbe0bc5c9d92c25c7bfba8ef491bd21e9c9c891f1 (patch)
treea6e8b548936cb6ceb75c2eba959ad178f8170e9c /dev-java/osgi-annotation/osgi-annotation-8.1.0.ebuild
parentprofiles: add prefix-standalone profile for riscv (diff)
downloadgentoo-be0bc5c9d92c25c7bfba8ef491bd21e9c9c891f1.tar.gz
gentoo-be0bc5c9d92c25c7bfba8ef491bd21e9c9c891f1.tar.bz2
gentoo-be0bc5c9d92c25c7bfba8ef491bd21e9c9c891f1.zip
dev-java/osgi-annotation: new package, add 8.1.0
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/osgi-annotation/osgi-annotation-8.1.0.ebuild')
-rw-r--r--dev-java/osgi-annotation/osgi-annotation-8.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-java/osgi-annotation/osgi-annotation-8.1.0.ebuild b/dev-java/osgi-annotation/osgi-annotation-8.1.0.ebuild
new file mode 100644
index 000000000000..4c5826cb0bc6
--- /dev/null
+++ b/dev-java/osgi-annotation/osgi-annotation-8.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.osgi:osgi.annotation:8.1.0"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="OSGi Annotation Release 8, Annotations for use in compiling bundles"
+HOMEPAGE="https://www.osgi.org"
+SRC_URI="https://docs.osgi.org/download/r$(ver_cut 1)/${PN/-/.}-${PV}.jar -> ${P}.jar"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND=">=virtual/jdk-1.8:*"
+BDEPEND="app-arch/unzip"
+
+JAVA_SRC_DIR="OSGI-OPT/src"
+
+src_prepare() {
+ default
+ java-pkg_clean org
+}