summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/swingx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/swingx')
-rw-r--r--dev-java/swingx/Manifest2
-rw-r--r--dev-java/swingx/metadata.xml8
-rw-r--r--dev-java/swingx/swingx-1.6.4.ebuild35
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/swingx/Manifest b/dev-java/swingx/Manifest
new file mode 100644
index 000000000000..6f3390918230
--- /dev/null
+++ b/dev-java/swingx/Manifest
@@ -0,0 +1,2 @@
+DIST swingx-all-1.6.4-sources.jar 1296323 SHA256 e6ce0e1ac0ef16776a55f32fac17a39219577437ace6fa7f1eb96e885e1a6bf5 SHA512 d58964507b3e11b74089040f07699076c84520ab46feb8cb6aeea3e0f23c0cdb14f66d2c019ff8f7f0e911599efe543a47c103f7b1fc4829a483d65458f3fb55 WHIRLPOOL 780c0e19b733a1a2b45f9c50a3de99b4b251a4bf90b3622142e6b37507ae5155f014e7e3e886c4f104638c7fea7eb667ccdaef1346dedbae529812c12323187a
+DIST swingx-mavensupport-1.6.4-sources.jar 2793 SHA256 4ca7f1a31e84e2f92581505c453c8d2236260da9ebe15e2b864416fb686b34a0 SHA512 48fde1b0367373516e549919912f08e751fc4e0f964a9f8ae86d9d93813006253782ce2097e54663dd5eb639ab82dbf59fe61defedecd64a0e36e25a14a40d45 WHIRLPOOL 217ab4b5d8014dbb3ad536d376411e47ab32b6e1f4e91bceb3d4fc58f6fff1804b035a4d080a078a59c39c0af990d7400ee7eedb18593d236f4f88effb7bd8cc
diff --git a/dev-java/swingx/metadata.xml b/dev-java/swingx/metadata.xml
new file mode 100644
index 000000000000..82a57ccd5243
--- /dev/null
+++ b/dev-java/swingx/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/dev-java/swingx/swingx-1.6.4.ebuild b/dev-java/swingx/swingx-1.6.4.ebuild
new file mode 100644
index 000000000000..bcbfd9b7536f
--- /dev/null
+++ b/dev-java/swingx/swingx-1.6.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A collection of powerful, useful, and just plain fun Swing components"
+HOMEPAGE="https://java.net/projects/swingx/"
+SRC_URI="https://java.net/projects/${PN}/downloads/download/releases/${PN}-all-${PV}-sources.jar
+ https://java.net/projects/${PN}/downloads/download/releases/${PN}-mavensupport-${PV}-sources.jar"
+
+LICENSE="LGPL-2.1"
+SLOT="1.6"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/metainf-services:0"
+
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.5
+ ${CDEPEND}"
+
+JAVA_GENTOO_CLASSPATH="metainf-services"
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/api
+ use source && java-pkg_dosrc org
+}