summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/wstx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/wstx')
-rw-r--r--dev-java/wstx/Manifest1
-rw-r--r--dev-java/wstx/files/wstx-3.2.9-build.xml.patch13
-rw-r--r--dev-java/wstx/metadata.xml15
-rw-r--r--dev-java/wstx/wstx-3.2.9.ebuild64
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-java/wstx/Manifest b/dev-java/wstx/Manifest
new file mode 100644
index 000000000000..ccf388de7248
--- /dev/null
+++ b/dev-java/wstx/Manifest
@@ -0,0 +1 @@
+DIST wstx-src-3.2.9.zip 2218419 SHA256 b0f8489bbd1c5fdba8d39228686d75e18185e3052c887f7329bb9d313f9356c1 SHA512 316679a6586e453b85ffe4dd573a92019282b0d2028e931f33fafa8b0f3aef856c8326c72049ce42645e4b520bbd1bd91e74005f090dc22dc7ca7c76a0640117 WHIRLPOOL d1ee4b5eb3bb3de7e4ed3bd3cec72d0fe9cf068673d7c7702f28c61ab36d33e6ebe94e9e885a2530e50fd92d73c004339ad8a59bf0ac564d836af75225b05a79
diff --git a/dev-java/wstx/files/wstx-3.2.9-build.xml.patch b/dev-java/wstx/files/wstx-3.2.9-build.xml.patch
new file mode 100644
index 000000000000..58f689039cf6
--- /dev/null
+++ b/dev-java/wstx/files/wstx-3.2.9-build.xml.patch
@@ -0,0 +1,13 @@
+--- a/build.xml
++++ b/build.xml
+@@ -104,10 +104,6 @@
+ <include name="org/codehaus/stax2/**/*.class" />
+ </patternset>
+
+- <!-- 02-Mar-2009, TSa: Let's try automating Maven builds
+- -->
+- <import file="build-maven-deploy.xml" />
+-
+ <!-- And then something nifty, for creating minimal jars! -->
+
+ <classfileset id="j2meInputMinimal" dir="${BuildClassesDir}">
diff --git a/dev-java/wstx/metadata.xml b/dev-java/wstx/metadata.xml
new file mode 100644
index 000000000000..e067f959642b
--- /dev/null
+++ b/dev-java/wstx/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>mike@weisso.com</email>
+ <name>Mike Weissman</name>
+ </maintainer>
+ <longdescription lang="en">
+ Woodstox is a high-performance validating namespace-aware StAX-compliant
+ (JSR-173) Open Source XML-processor written in Java.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/dev-java/wstx/wstx-3.2.9.ebuild b/dev-java/wstx/wstx-3.2.9.ebuild
new file mode 100644
index 000000000000..a9852b817a16
--- /dev/null
+++ b/dev-java/wstx/wstx-3.2.9.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+WANT_ANT_TASKS="ant-nodeps"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Woodstox is a high-performance validating namespace-aware XML-processor"
+HOMEPAGE="http://woodstox.codehaus.org/"
+SRC_URI="http://woodstox.codehaus.org/${PV}/${PN}-src-${PV}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="3.2"
+KEYWORDS="amd64 ppc ppc64 x86"
+
+COMMON_DEP="
+ dev-java/emma:0
+ dev-java/sax:0
+ java-virtuals/jaxp-virtual
+ dev-java/stax:0
+ dev-java/msv:0
+ dev-java/xsdlib:0
+ dev-java/relaxng-datatype:0
+ dev-java/junit:0"
+
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+EANT_BUILD_TARGET="jars"
+EANT_DOC_TARGET="javadoc"
+
+# Don't need to make a folder
+S="${WORKDIR}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+java_prepare() {
+ rm -v lib/msv/*.jar || die
+ rm -v lib/*.jar || die
+
+ # Get rid of a missing include.
+ epatch "${FILESDIR}"/${P}-build.xml.patch
+}
+
+EANT_GENTOO_CLASSPATH="emma,sax,jaxp-virtual,msv,xsdlib,relaxng-datatype,junit"
+
+src_test(){
+ ANT_TASKS="ant-junit ant-nodeps ant-trax" eant test || die "Tests failed"
+}
+
+src_install() {
+ java-pkg_newjar build/"${PN}"-api-"${PV}".jar "${PN}"-api.jar
+ java-pkg_newjar build/"${PN}"-asl-"${PV}".jar "${PN}".jar
+ use doc && java-pkg_dojavadoc build/javadoc
+ use source && java-pkg_dosrc src
+}