summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValérian Rousset <tharvik@users.noreply.github.com>2023-07-20 23:46:18 +0200
committerSam James <sam@gentoo.org>2023-07-20 23:31:58 +0100
commit4726fafc27371a5c8b627274f8e9ab8768286483 (patch)
tree9e66d8632bd82ecd5976037695d6ec176da26fa6 /dev-java
parentsys-libs/queue-standalone: keyword 0.1-r1 for ~m68k (diff)
downloadgentoo-4726fafc27371a5c8b627274f8e9ab8768286483.tar.gz
gentoo-4726fafc27371a5c8b627274f8e9ab8768286483.tar.bz2
gentoo-4726fafc27371a5c8b627274f8e9ab8768286483.zip
dev-java/zxing-javase: fix tests on openjdk:8
Closes: https://bugs.gentoo.org/910497 Signed-off-by: Valérian Rousset <tharvik@users.noreply.github.com> Closes: https://github.com/gentoo/gentoo/pull/31979 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/zxing-javase/files/3.5.1-test-available-formats.patch29
-rw-r--r--dev-java/zxing-javase/zxing-javase-3.5.1.ebuild11
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-java/zxing-javase/files/3.5.1-test-available-formats.patch b/dev-java/zxing-javase/files/3.5.1-test-available-formats.patch
new file mode 100644
index 000000000000..aa4101749419
--- /dev/null
+++ b/dev-java/zxing-javase/files/3.5.1-test-available-formats.patch
@@ -0,0 +1,29 @@
+--- a/src/test/java/com/google/zxing/client/j2se/MatrixToImageWriterTestCase.java
++++ b/src/test/java/com/google/zxing/client/j2se/MatrixToImageWriterTestCase.java
+@@ -17,7 +17,9 @@
+ package com.google.zxing.client.j2se;
+
+ import com.google.zxing.common.BitMatrix;
++import static org.hamcrest.CoreMatchers.hasItem;
+ import org.junit.Assert;
++import static org.junit.Assume.assumeThat;
+ import org.junit.Test;
+
+ import javax.imageio.ImageIO;
+@@ -25,6 +27,7 @@
+ import java.io.IOException;
+ import java.nio.file.Files;
+ import java.nio.file.Path;
++import java.util.Arrays;
+
+ /**
+ * Tests {@link MatrixToImageWriter}.
+@@ -52,6 +55,8 @@ private static void doTest(MatrixToImageConfig config) throws IOException {
+ }
+
+ private static void doTestFormat(String format, MatrixToImageConfig config) throws IOException {
++ assumeThat(Arrays.asList(ImageIO.getWriterFormatNames()), hasItem(format));
++
+ int width = 2;
+ int height = 3;
+ BitMatrix matrix = new BitMatrix(width, height);
diff --git a/dev-java/zxing-javase/zxing-javase-3.5.1.ebuild b/dev-java/zxing-javase/zxing-javase-3.5.1.ebuild
index 6666b3db9dc2..ef015da75c4b 100644
--- a/dev-java/zxing-javase/zxing-javase-3.5.1.ebuild
+++ b/dev-java/zxing-javase/zxing-javase-3.5.1.ebuild
@@ -10,7 +10,7 @@ JAVA_TESTING_FRAMEWORKS="junit-4"
inherit java-pkg-2 java-pkg-simple
DESCRIPTION="Core barcode encoding/decoding library"
-HOMEPAGE="https://github.com/zxing/zxing/core"
+HOMEPAGE="https://github.com/zxing/zxing"
SRC_URI="https://github.com/zxing/zxing/archive/zxing-${PV}.tar.gz"
LICENSE="Apache-2.0"
SLOT="3"
@@ -31,7 +31,16 @@ RDEPEND="
S="${WORKDIR}/zxing-zxing-${PV}/javase"
+PATCHES=(
+ "${FILESDIR}/${PV}-test-available-formats.patch"
+)
+
JAVA_AUTOMATIC_MODULE_NAME="com.google.zxing.javase"
JAVA_SRC_DIR="src/main/java"
JAVA_TEST_GENTOO_CLASSPATH="junit-4"
JAVA_TEST_SRC_DIR="src/test/java"
+
+src_prepare() {
+ default # apply PATCHES
+ java-pkg-2_src_prepare
+}