summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-26 02:02:46 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-26 09:12:43 -0400
commit1ca47163c2c7c223d2a120092c2489d007e4eeb7 (patch)
tree2e634fbfab023dda39c79032451463b24602edf5 /dev-lang/julia
parentsci-libs/spqr: update EAPI 7 -> 8 (diff)
downloadgentoo-1ca47163c2c7c223d2a120092c2489d007e4eeb7.tar.gz
gentoo-1ca47163c2c7c223d2a120092c2489d007e4eeb7.tar.bz2
gentoo-1ca47163c2c7c223d2a120092c2489d007e4eeb7.zip
dev-lang/julia: mark as LTO-unsafe
julia has many problems, at many levels. Among these, it fails to build with LTO due to various errors somewhat more inventive than the norm when it comes to LTO issues. Iteration time on building and testing it is, of course, horrifically bad as it bundles its own private LLVM. I won't even try to run the testsuite. I tried that years ago on Arch. "Flaky" doesn't even begin to describe it -- an actual passing test result sometimes took me 7 builds in a row, and one is never sure why it actually passed for once. "Fortunately", the ebuild restricts tests anyway. Needless to say, who knows if it actually works. It seems to build. Probably. At least better than when -flto is used, so that's a win. On which note, it is worth pointing out: the ebuild *tried* to filter lto, but didn't do so early enough. This change simply lifts the filter early enough that it runs before a sed inserts CFLAGS into a Makefile, so that the filter actually takes effect. Bug NOT reported upstream. Julia is a language of all time, and reporting bugs gets you nowhere except the receiving end of a thorough gaslighting. I do not volunteer for this. The software is most likely broken (LTO warnings don't indicate a flawless codebase) but I simply don't care -- it's not my problem if this programming language is broken, as long as it isn't an obstacle to other, more useful packages, being safe to build by default with LTO enabled in make.conf. Closes: https://bugs.gentoo.org/855602 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-lang/julia')
-rw-r--r--dev-lang/julia/julia-1.8.3-r4.ebuild7
-rw-r--r--dev-lang/julia/julia-1.8.5-r1.ebuild7
-rw-r--r--dev-lang/julia/julia-1.9.0.ebuild7
-rw-r--r--dev-lang/julia/julia-1.9.4.ebuild7
4 files changed, 16 insertions, 12 deletions
diff --git a/dev-lang/julia/julia-1.8.3-r4.ebuild b/dev-lang/julia/julia-1.8.3-r4.ebuild
index c21a564cc460..997f4870446f 100644
--- a/dev-lang/julia/julia-1.8.3-r4.ebuild
+++ b/dev-lang/julia/julia-1.8.3-r4.ebuild
@@ -88,6 +88,10 @@ src_unpack() {
src_prepare() {
default
+ # Various LTO issues.
+ # https://bugs.gentoo.org/855602
+ filter-lto
+
# Sledgehammer:
# - prevent fetching of bundled stuff in compile and install phase
# - respect CFLAGS
@@ -106,9 +110,6 @@ src_prepare() {
}
src_configure() {
- # bug #855602
- filter-lto
-
# julia does not play well with the system versions of libuv
# Fails to compile with libpcre2 on split-usr, bug #893336
# USE_SYSTEM_LIBM=0 implies using external openlibm
diff --git a/dev-lang/julia/julia-1.8.5-r1.ebuild b/dev-lang/julia/julia-1.8.5-r1.ebuild
index c38278524dae..5c62824bd624 100644
--- a/dev-lang/julia/julia-1.8.5-r1.ebuild
+++ b/dev-lang/julia/julia-1.8.5-r1.ebuild
@@ -121,6 +121,10 @@ src_unpack() {
src_prepare() {
default
+ # Various LTO issues.
+ # https://bugs.gentoo.org/855602
+ filter-lto
+
# Sledgehammer:
# - prevent fetching of bundled stuff in compile and install phase
# - respect CFLAGS
@@ -146,9 +150,6 @@ src_prepare() {
}
src_configure() {
- # bug #855602
- filter-lto
-
# julia does not play well with the system versions of libuv
# Fails to compile with libpcre2 on split-usr, bug #893336
# USE_SYSTEM_LIBM=0 implies using external openlibm
diff --git a/dev-lang/julia/julia-1.9.0.ebuild b/dev-lang/julia/julia-1.9.0.ebuild
index 6dfef422bd55..d1c6e722a101 100644
--- a/dev-lang/julia/julia-1.9.0.ebuild
+++ b/dev-lang/julia/julia-1.9.0.ebuild
@@ -101,6 +101,10 @@ src_unpack() {
src_prepare() {
default
+ # Various LTO issues.
+ # https://bugs.gentoo.org/855602
+ filter-lto
+
# Sledgehammer:
# - prevent fetching of bundled stuff in compile and install phase
# - respect CFLAGS
@@ -126,9 +130,6 @@ src_prepare() {
}
src_configure() {
- # bug #855602
- filter-lto
-
# julia does not play well with the system versions of libuv
# Fails to compile with libpcre2 on split-usr, bug #893336
# USE_SYSTEM_LIBM=0 implies using external openlibm
diff --git a/dev-lang/julia/julia-1.9.4.ebuild b/dev-lang/julia/julia-1.9.4.ebuild
index 82e0fb7987d9..9a747305e8d0 100644
--- a/dev-lang/julia/julia-1.9.4.ebuild
+++ b/dev-lang/julia/julia-1.9.4.ebuild
@@ -91,6 +91,10 @@ src_unpack() {
src_prepare() {
default
+ # Various LTO issues.
+ # https://bugs.gentoo.org/855602
+ filter-lto
+
# Sledgehammer:
# - prevent fetching of bundled stuff in compile and install phase
# - respect CFLAGS
@@ -109,9 +113,6 @@ src_prepare() {
}
src_configure() {
- # bug #855602
- filter-lto
-
# julia does not play well with the system versions of libuv
# Fails to compile with libpcre2 on split-usr, bug #893336
# USE_SYSTEM_LIBM=0 implies using external openlibm