summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-08-28 16:44:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-08-29 20:39:08 +0200
commit317434e07e6f785b6857d504cbd6225c688f1c21 (patch)
treeb3f56d4718636975a9af2e32bf0621f7edd4b1a8 /dev-lang/micropython
parentdev-lang/smlnj: drop 110.82, 110.99.2, EAPI-6-- (diff)
downloadgentoo-317434e07e6f785b6857d504cbd6225c688f1c21.tar.gz
gentoo-317434e07e6f785b6857d504cbd6225c688f1c21.tar.bz2
gentoo-317434e07e6f785b6857d504cbd6225c688f1c21.zip
dev-lang/micropython: drop 1.11-r1, EAPI-6--
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-lang/micropython')
-rw-r--r--dev-lang/micropython/Manifest1
-rw-r--r--dev-lang/micropython/files/micropython-1.11-exclude-float-parse-tests.patch12
-rw-r--r--dev-lang/micropython/files/micropython-1.11-prevent-stripping.patch26
-rw-r--r--dev-lang/micropython/micropython-1.11-r1.ebuild65
4 files changed, 0 insertions, 104 deletions
diff --git a/dev-lang/micropython/Manifest b/dev-lang/micropython/Manifest
index e6e1460bf548..74304d0b18d1 100644
--- a/dev-lang/micropython/Manifest
+++ b/dev-lang/micropython/Manifest
@@ -1,2 +1 @@
-DIST micropython-1.11.tar.gz 23010708 BLAKE2B 8deb29f2a27b8299f62c8c3d332654889e610ddc6854dc38c6cf7504c89f2f9cbbacccdc2d8e471d96b8bb28bbb920fe7ec1b8fd49b14209924262f54687c3c1 SHA512 255860e56bf51c4f35a00cf66fff3ee37fbef1e0d674af6ed580367d8b3d2d60fb88609a675e8f322fd466a23006e38078b67edd6f306e639d6be12abb2972d2
DIST micropython-1.17.tar.xz 56606868 BLAKE2B a6338d173de646764c1573ebabdb9818746a479fd2dd618f9be9955881e3829c4d89da4602934e71655734ec1c6f2150a6ac2c54a5fed9bee998905a00d5c6ea SHA512 8074214040e35ae1ca99721ec442f4cef70fa03380b7662016c55cb3acff9178fc54140c0d818c9581389b4daaade142ecf75b65a2919c666a50255423a39a54
diff --git a/dev-lang/micropython/files/micropython-1.11-exclude-float-parse-tests.patch b/dev-lang/micropython/files/micropython-1.11-exclude-float-parse-tests.patch
deleted file mode 100644
index 6d81661790e9..000000000000
--- a/dev-lang/micropython/files/micropython-1.11-exclude-float-parse-tests.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/tests/run-tests 2020-06-09 13:09:24.239121947 -0000
-+++ b/tests/run-tests 2020-06-09 13:09:57.315476363 -0000
-@@ -377,6 +377,9 @@
- skip_tests.add('micropython/heapalloc_traceback.py') # because native doesn't have proper traceback info
- skip_tests.add('micropython/schedule.py') # native code doesn't check pending events
-
-+ skip_tests.add('float/float_parse.py')
-+ skip_tests.add('float/float_parse_doubleprec.py')
-+ # these two tests fail for some reason.
- for test_file in tests:
- test_file = test_file.replace('\\', '/')
-
diff --git a/dev-lang/micropython/files/micropython-1.11-prevent-stripping.patch b/dev-lang/micropython/files/micropython-1.11-prevent-stripping.patch
deleted file mode 100644
index 7b78b6fb9f60..000000000000
--- a/dev-lang/micropython/files/micropython-1.11-prevent-stripping.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/py/mkenv.mk b/py/mkenv.mk
-index 46eedf9..2f3f3ca 100644
---- a/py/mkenv.mk
-+++ b/py/mkenv.mk
-@@ -52,7 +52,6 @@ CXX = $(CROSS_COMPILE)g++
- LD = $(CROSS_COMPILE)ld
- OBJCOPY = $(CROSS_COMPILE)objcopy
- SIZE = $(CROSS_COMPILE)size
--STRIP = $(CROSS_COMPILE)strip
- AR = $(CROSS_COMPILE)ar
- ifeq ($(MICROPY_FORCE_32BIT),1)
- CC += -m32
-diff --git a/py/mkrules.mk b/py/mkrules.mk
-index 4e4fdef..149b337 100644
---- a/py/mkrules.mk
-+++ b/py/mkrules.mk
-@@ -133,9 +133,6 @@ $(PROG): $(OBJ)
- # Do not pass COPT here - it's *C* compiler optimizations. For example,
- # we may want to compile using Thumb, but link with non-Thumb libc.
- $(Q)$(CC) -o $@ $^ $(LIB) $(LDFLAGS)
--ifndef DEBUG
-- $(Q)$(STRIP) $(STRIPFLAGS_EXTRA) $(PROG)
--endif
- $(Q)$(SIZE) $$(find $(BUILD) -path "$(BUILD)/build/frozen*.o") $(PROG)
-
- clean: clean-prog
diff --git a/dev-lang/micropython/micropython-1.11-r1.ebuild b/dev-lang/micropython/micropython-1.11-r1.ebuild
deleted file mode 100644
index 57a5d6bee6a3..000000000000
--- a/dev-lang/micropython/micropython-1.11-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="Python implementation for microcontrollers"
-HOMEPAGE="https://github.com/micropython/micropython"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-libs/libffi:=
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/${P}-prevent-stripping.patch"
- "${FILESDIR}/${P}-exclude-float-parse-tests.patch"
-)
-
-src_prepare() {
- default
-
- cd ports/unix || die
-
- # 1) don't die on compiler warning
- # 2) remove /usr/local prefix references in favour of /usr
- # 3) enforce our CFLAGS
- # 4) enforce our LDFLAGS
- sed -e 's#-Werror##g;' \
- -e 's#\/usr\/local#\/usr#g;' \
- -e "s#^CFLAGS = \(.*\)#CFLAGS = \1 ${CFLAGS}#g" \
- -e "s#^LDFLAGS = \(.*\)#LDFLAGS = \1 ${LDFLAGS}#g" \
- -i Makefile || die "can't patch Makefile"
-}
-
-src_compile() {
- cd ports/unix || die
-
- emake CC="$(tc-getCC)" axtls
- emake CC="$(tc-getCC)"
-}
-
-src_test() {
- cd ports/unix || die
- emake CC="$(tc-getCC)" test
-}
-
-src_install() {
- pushd ports/unix > /dev/null || die
- emake CC="$(tc-getCC)" DESTDIR="${D}" install
- popd > /dev/null || die
-
- # remove .git files
- find tools -type f -name '.git*' -exec rm {} \; || die
-
- dodoc -r tools
- einstalldocs
-}