summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2019-08-07 21:59:09 +1200
committerKent Fredric <kentnl@gentoo.org>2019-08-07 23:41:45 +1200
commit07051bf7565cea2a153d22d3c41205de48ca54ad (patch)
tree4abcc7ee5f5f1689119cd3d1e7154874470b6560 /dev-lang/nqp/nqp-9999.ebuild
parentdev-lang/nqp: Trim useless blank in 2018.06.ebuild (diff)
downloadgentoo-07051bf7565cea2a153d22d3c41205de48ca54ad.tar.gz
gentoo-07051bf7565cea2a153d22d3c41205de48ca54ad.tar.bz2
gentoo-07051bf7565cea2a153d22d3c41205de48ca54ad.zip
dev-lang/nqp: Force JDK/JRE 8 in dependencies
Due to jdk/jre-1.7 being mentioned in (R)DEPEND, java-pkg_javac-args injects "-source 1.7 -target 1.7" into the javac invocation, which is silly, as nqp then appends "-source 1.8" to it anyway, resulting in: javac -source 1.7 -target 1.7 -source 1.8 .... And javac then barfs: javac: source release 1.8 requires target release 1.8 Bumping the values in DEPENDS changes the javac invocation to: javac -source 1.8 -target 1.8 -source 1.8 ... Which of course then works. Subsequently, all existing nqp versions (other than -9999) now work for me with USE="java" just fine, where previously they wouldn't work at all. Closes: https://bugs.gentoo.org/631226 Closes: https://bugs.gentoo.org/626486 Closes: https://bugs.gentoo.org/635902 Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-lang/nqp/nqp-9999.ebuild')
-rw-r--r--dev-lang/nqp/nqp-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-lang/nqp/nqp-9999.ebuild b/dev-lang/nqp/nqp-9999.ebuild
index 9c9a3c5b474b..61c5c890f018 100644
--- a/dev-lang/nqp/nqp-9999.ebuild
+++ b/dev-lang/nqp/nqp-9999.ebuild
@@ -29,10 +29,10 @@ CDEPEND="java? (
)
moar? ( ~dev-lang/moarvm-${PV}[clang=] )"
RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.7 )"
+ java? ( >=virtual/jre-1.8 )"
DEPEND="${CDEPEND}
clang? ( sys-devel/clang )
- java? ( >=virtual/jdk-1.7 )
+ java? ( >=virtual/jdk-1.8 )
dev-lang/perl"
pkg_pretend() {