summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-16 07:30:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-16 08:48:28 +0200
commit79f139713ed51c4c053064464f0fe465ec958704 (patch)
tree4594044ee9f7086c65ab825ce383d9b73cfc73f4 /dev-lang/python
parentdev-python/elasticsearch: Bump to 8.14.0 (diff)
downloadgentoo-79f139713ed51c4c053064464f0fe465ec958704.tar.gz
gentoo-79f139713ed51c4c053064464f0fe465ec958704.tar.bz2
gentoo-79f139713ed51c4c053064464f0fe465ec958704.zip
dev-lang/python: Remove obsolete postinst from 3.12+
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-3.12.4_p1.ebuild16
-rw-r--r--dev-lang/python/python-3.13.0_beta2_p3.ebuild16
2 files changed, 0 insertions, 32 deletions
diff --git a/dev-lang/python/python-3.12.4_p1.ebuild b/dev-lang/python/python-3.12.4_p1.ebuild
index f7e54652dedc..bec993fb2e80 100644
--- a/dev-lang/python/python-3.12.4_p1.ebuild
+++ b/dev-lang/python/python-3.12.4_p1.ebuild
@@ -556,19 +556,3 @@ src_install() {
ln -s "../../../bin/idle${PYVER}" "${scriptdir}/idle" || die
fi
}
-
-pkg_postinst() {
- local v
- for v in ${REPLACING_VERSIONS}; do
- if ver_test "${v}" -lt 3.11.0_beta4-r2; then
- ewarn "Python 3.11.0b4 has changed its module ABI. The .pyc files"
- ewarn "installed previously are no longer valid and will be regenerated"
- ewarn "(or ignored) on the next import. This may cause sandbox failures"
- ewarn "when installing some packages and checksum mismatches when removing"
- ewarn "old versions. To actively prevent this, rebuild all packages"
- ewarn "installing Python 3.11 modules, e.g. using:"
- ewarn
- ewarn " emerge -1v /usr/lib/python3.11/site-packages"
- fi
- done
-}
diff --git a/dev-lang/python/python-3.13.0_beta2_p3.ebuild b/dev-lang/python/python-3.13.0_beta2_p3.ebuild
index 792927c05468..d8206dba60a4 100644
--- a/dev-lang/python/python-3.13.0_beta2_p3.ebuild
+++ b/dev-lang/python/python-3.13.0_beta2_p3.ebuild
@@ -666,19 +666,3 @@ src_install() {
ln -s "../../../bin/idle${PYVER}" "${scriptdir}/idle" || die
fi
}
-
-pkg_postinst() {
- local v
- for v in ${REPLACING_VERSIONS}; do
- if ver_test "${v}" -lt 3.11.0_beta4-r2; then
- ewarn "Python 3.11.0b4 has changed its module ABI. The .pyc files"
- ewarn "installed previously are no longer valid and will be regenerated"
- ewarn "(or ignored) on the next import. This may cause sandbox failures"
- ewarn "when installing some packages and checksum mismatches when removing"
- ewarn "old versions. To actively prevent this, rebuild all packages"
- ewarn "installing Python 3.11 modules, e.g. using:"
- ewarn
- ewarn " emerge -1v /usr/lib/python3.11/site-packages"
- fi
- done
-}