summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2023-06-07 14:55:13 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2023-06-07 15:02:35 -0700
commit188cb565103e7fe90f03793b0f32ed6a575d5a11 (patch)
tree35fa1b44355a41a5bbb203ce62ba50608e7b36e9 /dev-lang
parentdev-lang/rust-bin: keyword 1.70.0, restrict strip (diff)
downloadgentoo-188cb565103e7fe90f03793b0f32ed6a575d5a11.tar.gz
gentoo-188cb565103e7fe90f03793b0f32ed6a575d5a11.tar.bz2
gentoo-188cb565103e7fe90f03793b0f32ed6a575d5a11.zip
dev-lang/rust: keyword 1.70.0
Bug: https://bugs.gentoo.org/907961 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust/rust-1.70.0.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-lang/rust/rust-1.70.0.ebuild b/dev-lang/rust/rust-1.70.0.ebuild
index 873e2dff63fe..33820a266181 100644
--- a/dev-lang/rust/rust-1.70.0.ebuild
+++ b/dev-lang/rust/rust-1.70.0.ebuild
@@ -19,7 +19,7 @@ else
SLOT="stable/${ABI_VER}"
MY_P="rustc-${PV}"
SRC="${MY_P}-src.tar.xz"
- #KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
RUST_STAGE0_VERSION="1.$(($(ver_cut 2) - 1)).0"
@@ -124,6 +124,7 @@ RDEPEND="${DEPEND}
REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )
miri? ( nightly )
parallel-compiler? ( nightly )
+ rust-analyzer? ( rust-src )
test? ( ${ALL_LLVM_TARGETS[*]} )
wasm? ( llvm_targets_WebAssembly )
x86? ( cpu_flags_x86_sse2 )