summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-12 00:04:32 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-12 00:22:51 +0100
commitc949a5ddc4351726450cac22d82a8ad9abb12f8c (patch)
tree71c58e56dafe6890cb466386a33287e96cf28b64 /dev-lang
parentdev-lang/coffee-script: bump to 2.7.0 (diff)
downloadgentoo-c949a5ddc4351726450cac22d82a8ad9abb12f8c.tar.gz
gentoo-c949a5ddc4351726450cac22d82a8ad9abb12f8c.tar.bz2
gentoo-c949a5ddc4351726450cac22d82a8ad9abb12f8c.zip
dev-lang/coffee-script: rename cake -> coffee-cake
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/coffee-script/coffee-script-2.7.0.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-lang/coffee-script/coffee-script-2.7.0.ebuild b/dev-lang/coffee-script/coffee-script-2.7.0.ebuild
index 7dd220bd7837..2f497e582b0f 100644
--- a/dev-lang/coffee-script/coffee-script-2.7.0.ebuild
+++ b/dev-lang/coffee-script/coffee-script-2.7.0.ebuild
@@ -5,6 +5,8 @@ EAPI=8
MY_PN="coffeescript"
+inherit readme.gentoo-r1
+
DESCRIPTION="A little language that compiles into javascript"
HOMEPAGE="https://coffeescript.org/"
SRC_URI="https://github.com/jashkenas/${MY_PN}/archive/${PV}.tar.gz
@@ -23,6 +25,9 @@ RDEPEND="
net-libs/nodejs
"
+DOC_CONTENTS="To enable installation alongside other tools the Gentoo
+maintainer decided to rename the \"cake\" executable to \"coffee-cake\"."
+
src_install() {
local npm_module_dir="/usr/$(get_libdir)/node/${PN}"
@@ -50,6 +55,12 @@ src_install() {
exeinto "${npm_module_dir}/bin"
doexe bin/cake
doexe bin/coffee
- dosym "${npm_module_dir}/bin/cake" "/usr/bin/cake"
+ dosym "${npm_module_dir}/bin/cake" "/usr/bin/coffee-cake"
dosym "${npm_module_dir}/bin/coffee" "/usr/bin/coffee"
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
}