summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2022-01-29 07:11:34 +0000
committerIonen Wolkens <ionen@gentoo.org>2022-02-06 14:33:47 -0500
commita66a39de9b7a4a7e19ab2ae7af65c361c6dea97c (patch)
tree36595563d55ee3b8005aa206ae459c8776fb4981 /dev-libs/boxfort
parentdev-cpp/string-theory: EAPI7->8 (diff)
downloadgentoo-a66a39de9b7a4a7e19ab2ae7af65c361c6dea97c.tar.gz
gentoo-a66a39de9b7a4a7e19ab2ae7af65c361c6dea97c.tar.bz2
gentoo-a66a39de9b7a4a7e19ab2ae7af65c361c6dea97c.zip
dev-libs/boxfort: bump to 0.1.2
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24011 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-libs/boxfort')
-rw-r--r--dev-libs/boxfort/Manifest1
-rw-r--r--dev-libs/boxfort/boxfort-0.1.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/boxfort/Manifest b/dev-libs/boxfort/Manifest
index 6faa393f8a8b..8861f03a6151 100644
--- a/dev-libs/boxfort/Manifest
+++ b/dev-libs/boxfort/Manifest
@@ -1,2 +1,3 @@
DIST boxfort-0.0.1_pre20200902.tar.gz 41643 BLAKE2B 6ac53b632f604ffd6b790a026703a2d64da65fc03cc71ebc3e4da3463e7c5a44ec99e85e3cdac8e5756afaf7d98785955815e194929bbc8dd6b6fd90bfb3fd52 SHA512 96090372f3e546f53f82c515c3f9e557fdd67eb7bc735683b30d8a66c2536cf21261b0467e449ccbd13e914b7cf4ea3da1a37c4108b215d6d0d08cdb68944b1e
DIST boxfort-0.1.1.tar.gz 41993 BLAKE2B b9153a6330cecb781e2b5cd20554df3d0aad277dfc01174fd5d375211896b2912f26a76b0ba6ef7143c7101d844072e1a857caf5a8191893f22c0528c0a203d4 SHA512 48f7a0a52d03f36307271c8f387613dd53aebb19d0379e1758d557b043854c89068776ca4c22e64eb518429dd629c9a082476ecd2a548ac95e6aebef512a50ca
+DIST boxfort-0.1.2.tar.gz 42671 BLAKE2B 1053095fb6ffa16353fc9d34f99e556aa10fc05d1bd103e9cd6c0a4c332c09951e563ccb61ee8fcd983c247b3e9d2b7611f5f503d4d1bf5394103cc70aeccf60 SHA512 c381eb9a0947a9f8f2cbbb2db6bbaf76f1c328b5637bdd1d823590ead098bd741e015e415f49c55590b4f4fee3be19c5e23661df5fbbdc9a4a05c82d7c3293e5
diff --git a/dev-libs/boxfort/boxfort-0.1.2.ebuild b/dev-libs/boxfort/boxfort-0.1.2.ebuild
new file mode 100644
index 000000000000..67faa22bc260
--- /dev/null
+++ b/dev-libs/boxfort/boxfort-0.1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="Convenient & cross-platform sandboxing C library"
+HOMEPAGE="https://github.com/Snaipe/BoxFort"
+SRC_URI="https://github.com/Snaipe/BoxFort/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 -riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? (
+ $(python_gen_any_dep 'dev-util/cram[${PYTHON_USEDEP}]')
+ )"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/BoxFort-${PV}"
+
+python_check_deps() {
+ use test && has_version "dev-util/cram[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dsamples=$(usex test true false)
+ -Dtests=$(usex test true false)
+ )
+
+ meson_src_configure
+}