summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/collada-dom
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/collada-dom')
-rw-r--r--dev-libs/collada-dom/Manifest2
-rw-r--r--dev-libs/collada-dom/collada-dom-2.4.0.ebuild25
-rw-r--r--dev-libs/collada-dom/collada-dom-2.4.3_pre20150112.ebuild41
-rw-r--r--dev-libs/collada-dom/collada-dom-9999.ebuild37
-rwxr-xr-xdev-libs/collada-dom/files/take_snapshot.sh14
-rw-r--r--dev-libs/collada-dom/metadata.xml11
6 files changed, 130 insertions, 0 deletions
diff --git a/dev-libs/collada-dom/Manifest b/dev-libs/collada-dom/Manifest
new file mode 100644
index 000000000000..bd9fdb062959
--- /dev/null
+++ b/dev-libs/collada-dom/Manifest
@@ -0,0 +1,2 @@
+DIST collada-dom-2.4.0.tgz 42517651 SHA256 5ca2d12f744bdceff0066ed3067b3b23d6859581fb0d657f98ba4487d8fa3896 SHA512 6de67dc0e631cd02c4bc5567667e7bcee4a41a137310326d5b8290e088a757f7313454028473df3e198f73b3c2db7572a437f7256e666b44ed34fe81d44229c1 WHIRLPOOL fedb8e8d8adeafdd8b4b6bf7860a005153d05fdcaed99949b8913ce51582f2bc5d4e4ff223ea012c2bba84eb889a7e5fb3c8752ad1ae0884fd0127a2a1e1b44f
+DIST collada-dom-2.4.3_pre20150112.tar.xz 2272092 SHA256 be928859dc71491420433aa86df03b14576bf97b0fa6982cde201b7dac120d98 SHA512 46c237c123a9d1b9cc8e07bf992b4386c064a3382b44be1347ab4bc6dce85f75ad59da0a5740f97c879c982e5a1119dcec5ced82d4dd725efd789021b0ead7f1 WHIRLPOOL a7e6266895ba6528ef680f5dbcecc8dd3a3c0d9227f9e53fdc31729dc5538b6aebbc110b9a9b6ba2aa77cf7ed863e0301c55db72a0b4766b780e900b8125a860
diff --git a/dev-libs/collada-dom/collada-dom-2.4.0.ebuild b/dev-libs/collada-dom/collada-dom-2.4.0.ebuild
new file mode 100644
index 000000000000..174791c9f727
--- /dev/null
+++ b/dev-libs/collada-dom/collada-dom-2.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="COLLADA Document Object Model (DOM) C++ Library"
+HOMEPAGE="http://collada-dom.sourceforge.net/"
+SRC_URI="mirror://sourceforge/collada-dom/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=[minizip]
+ dev-libs/libxml2
+ dev-libs/libpcre[cxx]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/dev-libs/collada-dom/collada-dom-2.4.3_pre20150112.ebuild b/dev-libs/collada-dom/collada-dom-2.4.3_pre20150112.ebuild
new file mode 100644
index 000000000000..8c9278537239
--- /dev/null
+++ b/dev-libs/collada-dom/collada-dom-2.4.3_pre20150112.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/rdiankov/collada-dom"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+elif [ "${PV%_pre*}" != "${PV}" ]; then
+ # snapshot
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/rdiankov/collada-dom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="COLLADA Document Object Model (DOM) C++ Library"
+HOMEPAGE="https://github.com/rdiankov/collada-dom"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=[minizip]
+ dev-libs/libxml2
+ dev-libs/libpcre[cxx]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/dev-libs/collada-dom/collada-dom-9999.ebuild b/dev-libs/collada-dom/collada-dom-9999.ebuild
new file mode 100644
index 000000000000..b6bdc5945366
--- /dev/null
+++ b/dev-libs/collada-dom/collada-dom-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/rdiankov/collada-dom"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/rdiankov/collada-dom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="COLLADA Document Object Model (DOM) C++ Library"
+HOMEPAGE="https://github.com/rdiankov/collada-dom"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=[minizip]
+ dev-libs/libxml2
+ dev-libs/libpcre[cxx]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/dev-libs/collada-dom/files/take_snapshot.sh b/dev-libs/collada-dom/files/take_snapshot.sh
new file mode 100755
index 000000000000..fcf9c75e3423
--- /dev/null
+++ b/dev-libs/collada-dom/files/take_snapshot.sh
@@ -0,0 +1,14 @@
+#!/bin/sh
+VERSION=$(date +%Y%m%d)
+PACKAGE="collada-dom-2.4.3_pre${VERSION}"
+
+git clone https://github.com/rdiankov/collada-dom ${PACKAGE}
+
+find "${PACKAGE}" -type d -name '.git' -prune -print0 | xargs -0 rm -rf
+
+tar cJf ${PACKAGE}.tar.xz ${PACKAGE}
+rm -rf ${PACKAGE}/
+
+echo "Tarball: \"${PACKAGE}.tar.xz\""
+
+echo "** all done **"
diff --git a/dev-libs/collada-dom/metadata.xml b/dev-libs/collada-dom/metadata.xml
new file mode 100644
index 000000000000..b259d804624b
--- /dev/null
+++ b/dev-libs/collada-dom/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rdiankov/collada-dom</remote-id>
+ </upstream>
+</pkgmetadata>