summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-12-04 18:41:38 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-12-04 18:41:38 +0000
commita2df9708b55b4bbcdf6fc81f03a3174f9d91583d (patch)
tree6e7f76a3a35429d5c5233937e1c10f49df91111c /dev-libs/distorm64
parentsys-libs/uid_wrapper: stable 1.2.8 for ppc64 (diff)
downloadgentoo-a2df9708b55b4bbcdf6fc81f03a3174f9d91583d.tar.gz
gentoo-a2df9708b55b4bbcdf6fc81f03a3174f9d91583d.tar.bz2
gentoo-a2df9708b55b4bbcdf6fc81f03a3174f9d91583d.zip
dev-libs/distorm64: bump up to 3.5.1
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-libs/distorm64')
-rw-r--r--dev-libs/distorm64/Manifest1
-rw-r--r--dev-libs/distorm64/distorm64-3.5.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/distorm64/Manifest b/dev-libs/distorm64/Manifest
index 8aea32b1892f..1c33e27fd381 100644
--- a/dev-libs/distorm64/Manifest
+++ b/dev-libs/distorm64/Manifest
@@ -1 +1,2 @@
DIST distorm3-3.5.0.tar.gz 137500 BLAKE2B 01d426f0b76a232503ebe4e1edb719bcdd1480a6ab729f3e49eff3e3fee5e9e4af6e6051c1e7675b14aa39a2fc999df2c1535976bb0981a23baef0e78aec8bd3 SHA512 ad9415a0a1a65a7ad3824b19ec83df90459eeb153494efb6623a8f02c60b6d0cf61d7dae4143eb1dd0586f5c7a7115f4a53cea5609296f703e5db612ce925011
+DIST distorm3-3.5.1.tar.gz 137638 BLAKE2B cecd29dd30a78514e8f8275fef6d0d8338f8d3f5c22b9b48abf2a156b9dc14626455db92172a9bcf6ce36fab8975149395437697a464ce8dd7fb73e9acfcad9d SHA512 0f4cc669c0c562f8458f29d7d6c5d6c308e4681c1c1737d9d81dd2d02e11e5af236b7084d1b24980d1bd0fac514a043bb83d3b6c499b731d43cb4b7458172c48
diff --git a/dev-libs/distorm64/distorm64-3.5.1.ebuild b/dev-libs/distorm64/distorm64-3.5.1.ebuild
new file mode 100644
index 000000000000..001d04eb4798
--- /dev/null
+++ b/dev-libs/distorm64/distorm64-3.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
+HOMEPAGE="http://www.ragestorm.net/distorm/"
+
+MY_PN=distorm3
+MY_P=${MY_PN}-${PV}
+
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=""
+RDEPEND=""
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_install() {
+ distutils-r1_python_install
+
+ # don't know why it does not happen by default
+ python_optimize
+}