summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-09-05 14:57:57 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-09-05 14:58:37 +0200
commit29b47cebadc750a9396c57fd28a27956a2c30113 (patch)
tree9714c68b718fc19c2940abf01a0c347a7d4e2ed9 /dev-libs/ell/ell-0.9.ebuild
parentapp-text/pdftk: Fix classpath issue via better wrapper params (diff)
downloadgentoo-29b47cebadc750a9396c57fd28a27956a2c30113.tar.gz
gentoo-29b47cebadc750a9396c57fd28a27956a2c30113.tar.bz2
gentoo-29b47cebadc750a9396c57fd28a27956a2c30113.zip
dev-libs/ell: Bump to version 0.9
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-libs/ell/ell-0.9.ebuild')
-rw-r--r--dev-libs/ell/ell-0.9.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/ell/ell-0.9.ebuild b/dev-libs/ell/ell-0.9.ebuild
new file mode 100644
index 000000000000..c3776ce019cd
--- /dev/null
+++ b/dev-libs/ell/ell-0.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Embedded Linux Library provides core, low-level functionality for system daemons"
+HOMEPAGE="https://01.org/ell"
+SRC_URI="https://mirrors.edge.kernel.org/pub/linux/libs/${PN}/${P}.tar.xz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="glib pie"
+
+RDEPEND="
+ glib? ( dev-libs/glib:2[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable glib)
+ $(use_enable pie)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ local DOCS=( ChangeLog README )
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+}