summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-02-23 14:29:50 +0200
committerMart Raudsepp <leio@gentoo.org>2020-02-23 14:30:48 +0200
commit61a9ee210b2d44c4fa953342504293a89395bef0 (patch)
tree01af3ad985aa04708ff3faf8e88443d4f505b096 /dev-libs/folks
parentsys-fs/lvm2: Backport the device-mapper-only + static-lib fix (diff)
downloadgentoo-61a9ee210b2d44c4fa953342504293a89395bef0.tar.gz
gentoo-61a9ee210b2d44c4fa953342504293a89395bef0.tar.bz2
gentoo-61a9ee210b2d44c4fa953342504293a89395bef0.zip
dev-libs/folks: fix USE=bluetooth build with meson-0.53
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/folks')
-rw-r--r--dev-libs/folks/files/0.12.1-meson-0.53-compat.patch47
-rw-r--r--dev-libs/folks/folks-0.12.1-r1.ebuild1
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/folks/files/0.12.1-meson-0.53-compat.patch b/dev-libs/folks/files/0.12.1-meson-0.53-compat.patch
new file mode 100644
index 000000000000..56f9543ba40a
--- /dev/null
+++ b/dev-libs/folks/files/0.12.1-meson-0.53-compat.patch
@@ -0,0 +1,47 @@
+From 1853567d79024c6ce960d9dc187cff8aaf9a37ce Mon Sep 17 00:00:00 2001
+From: Niels De Graef <nielsdegraef@gmail.com>
+Date: Mon, 3 Feb 2020 08:57:52 +0100
+Subject: [PATCH] meson: Use python.dependency() correctly
+
+From https://github.com/mesonbuild/meson/issues/6470:
+
+> So, to further clarify, passing an argument to
+> py_installation.dependency() should be an error, since this method
+> will only ever return a python dependency (for embedding python
+> itself, etc.) and not dbusmock or anything else.
+
+Fixxes https://gitlab.gnome.org/GNOME/folks/issues/119
+---
+ meson.build | 9 ++++++---
+ 1 file changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index d5115e28..f3644457 100644
+--- a/meson.build
++++ b/meson.build
+@@ -1,7 +1,7 @@
+ project('folks', [ 'vala', 'c' ],
+ version: '0.13.2',
+ license: 'LGPL2.1+',
+- meson_version: '>= 0.49',
++ meson_version: '>= 0.51',
+ )
+
+ gnome = import('gnome')
+@@ -132,8 +132,11 @@ if bluez_backend_enabled
+ libebook_dep = dependency('libebook-1.2', version: '>=' + min_eds_version)
+ # Needed for the BlueZ tests
+ pymod = import('python')
+- py_installation = pymod.find_installation('python3')
+- python_dbusmock = py_installation.dependency('dbusmock')
++ py_installation = pymod.find_installation('python3',
++ modules: [
++ 'dbusmock',
++ ],
++ )
+ endif
+
+ if import_tool_enabled
+--
+2.20.1
+
diff --git a/dev-libs/folks/folks-0.12.1-r1.ebuild b/dev-libs/folks/folks-0.12.1-r1.ebuild
index 65b227ad2319..51ddb26a5e31 100644
--- a/dev-libs/folks/folks-0.12.1-r1.ebuild
+++ b/dev-libs/folks/folks-0.12.1-r1.ebuild
@@ -49,6 +49,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PV}-conditional-tests.patch # Allow not building lots of test executables when tests are disabled
"${FILESDIR}"/${PV}-no-tracker-tests.patch # TODO: Tracker tests fail; this removed them for now
+ "${FILESDIR}"/${PV}-meson-0.53-compat.patch # https://gitlab.gnome.org/GNOME/folks/issues/119
)
src_prepare() {