summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2022-11-18 08:49:18 -0500
committerCraig Andrews <candrews@gentoo.org>2022-11-18 08:50:39 -0500
commit33535504fb8f44f14f123deaeda3bca3ecdfe9a4 (patch)
treed93d57f432c05589120c48cc39b3be863b86cb1c /dev-libs/gost-engine
parentsys-process/btop: Keyword 1.2.13 ppc, #881041 (diff)
downloadgentoo-33535504fb8f44f14f123deaeda3bca3ecdfe9a4.tar.gz
gentoo-33535504fb8f44f14f123deaeda3bca3ecdfe9a4.tar.bz2
gentoo-33535504fb8f44f14f123deaeda3bca3ecdfe9a4.zip
dev-libs/gost-engine: Depend on =dev-libs/openssl-1.1*:=
Bug: https://bugs.gentoo.org/881151 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/gost-engine')
-rw-r--r--dev-libs/gost-engine/gost-engine-1.1.0.3_p20181031-r3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/gost-engine/gost-engine-1.1.0.3_p20181031-r3.ebuild b/dev-libs/gost-engine/gost-engine-1.1.0.3_p20181031-r3.ebuild
new file mode 100644
index 000000000000..d6f82551ac1c
--- /dev/null
+++ b/dev-libs/gost-engine/gost-engine-1.1.0.3_p20181031-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A reference implementation of the Russian GOST crypto algorithms for OpenSSL"
+HOMEPAGE="https://github.com/gost-engine/engine"
+IUSE="test"
+RESTRICT="!test? ( test )"
+SLOT="0/${PV}"
+
+COMMON_DEPEND="=dev-libs/openssl-1.1*:0="
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-lang/perl
+ )"
+RDEPEND="${COMMON_DEPEND}"
+
+LICENSE="openssl"
+
+DOCS=( INSTALL.md README.gost README.md )
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/gost-engine/engine.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~hppa"
+ SRC_URI="https://github.com/gost-engine/engine/archive/e5cc3684f3b3ad40e186e23b00b253d234df92ab.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/engine-e5cc3684f3b3ad40e186e23b00b253d234df92ab"
+fi
+
+src_prepare() {
+ cmake_src_prepare
+ sed 's:Werror:Wno-error:g' -i "${S}/CMakeLists.txt" || die
+}