summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-01-03 17:35:56 -0500
committerCraig Andrews <candrews@gentoo.org>2023-01-03 17:42:26 -0500
commit92c1d157a0582aa48ae8d699a45c589dd35deee0 (patch)
tree958791856b86b7d3a066f715b644e5c153aaa8c3 /dev-libs/gost-engine
parentapp-containers/skopeo: add 1.10.0 (diff)
downloadgentoo-92c1d157a0582aa48ae8d699a45c589dd35deee0.tar.gz
gentoo-92c1d157a0582aa48ae8d699a45c589dd35deee0.tar.bz2
gentoo-92c1d157a0582aa48ae8d699a45c589dd35deee0.zip
dev-libs/gost-engine: fix build
libprov isn't included the GitHub generated release .tar.gz because it's a submodule. See: https://github.com/dear-github/dear-github/issues/214 Closes: https://bugs.gentoo.org/885983 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/gost-engine')
-rw-r--r--dev-libs/gost-engine/Manifest1
-rw-r--r--dev-libs/gost-engine/gost-engine-3.0.1.ebuild7
-rw-r--r--dev-libs/gost-engine/gost-engine-9999.ebuild7
3 files changed, 11 insertions, 4 deletions
diff --git a/dev-libs/gost-engine/Manifest b/dev-libs/gost-engine/Manifest
index d90de507d048..a4718bfbb589 100644
--- a/dev-libs/gost-engine/Manifest
+++ b/dev-libs/gost-engine/Manifest
@@ -1 +1,2 @@
DIST gost-engine-3.0.1.tar.gz 1645245 BLAKE2B 713a7343f9c11feec361dd2828b00dd7d47518f5a1b047a6e11f8d8eea206ce9058ace1bd70e12b4cb2200789eb8209de671cb5e2692e95391b4e7a82d0badc2 SHA512 eb9fb126393cfe23bcef0f45c05b38d39aadd8909419ebcf6dab4800bd7372b63891e9061f8e70686f8ba5cd58669681895b36320ed6a8cc0ca1ff037aa73b85
+DIST libprov-8a126e09547630ef900177625626b6156052f0ee.tar.gz 5693 BLAKE2B e2c9c1a6c31532ea830c94bca9a7e2f0c0d0688c628ba0851ff541a0d9fd9aa727c5ed9b78901032e928ea8cfb63483d3bfeadac40c61ddd990df00e2c7d3cd9 SHA512 4633ca9ad21585483dbaf28e416f0f3416c814bb41b0ccf036e438275d83393e70ed1c2cd0298fc87d8e928074a7afcf3971a0d790014cc0d200c92bb2defe4d
diff --git a/dev-libs/gost-engine/gost-engine-3.0.1.ebuild b/dev-libs/gost-engine/gost-engine-3.0.1.ebuild
index b9fc8e721abe..a66a0b40c861 100644
--- a/dev-libs/gost-engine/gost-engine-3.0.1.ebuild
+++ b/dev-libs/gost-engine/gost-engine-3.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,17 +23,20 @@ LICENSE="openssl"
DOCS=( INSTALL.md README.gost README.md )
+LIBPROV_COMMIT="8a126e09547630ef900177625626b6156052f0ee"
if [[ ${PV} == "9999" ]] ; then
SRC_URI=""
EGIT_REPO_URI="https://github.com/gost-engine/engine.git"
inherit git-r3
else
KEYWORDS="~amd64 ~hppa"
- SRC_URI="https://github.com/gost-engine/engine/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/gost-engine/engine/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/provider-corner/libprov/archive/${LIBPROV_COMMIT}.tar.gz -> libprov-${LIBPROV_COMMIT}.tar.gz"
S="${WORKDIR}/engine-${PV}"
fi
src_prepare() {
+ cp -R "${WORKDIR}/libprov-${LIBPROV_COMMIT}/." "${S}/libprov" || die
cmake_src_prepare
sed 's:Werror:Wno-error:g' -i "${S}/CMakeLists.txt" || die
}
diff --git a/dev-libs/gost-engine/gost-engine-9999.ebuild b/dev-libs/gost-engine/gost-engine-9999.ebuild
index b9fc8e721abe..a66a0b40c861 100644
--- a/dev-libs/gost-engine/gost-engine-9999.ebuild
+++ b/dev-libs/gost-engine/gost-engine-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,17 +23,20 @@ LICENSE="openssl"
DOCS=( INSTALL.md README.gost README.md )
+LIBPROV_COMMIT="8a126e09547630ef900177625626b6156052f0ee"
if [[ ${PV} == "9999" ]] ; then
SRC_URI=""
EGIT_REPO_URI="https://github.com/gost-engine/engine.git"
inherit git-r3
else
KEYWORDS="~amd64 ~hppa"
- SRC_URI="https://github.com/gost-engine/engine/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/gost-engine/engine/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/provider-corner/libprov/archive/${LIBPROV_COMMIT}.tar.gz -> libprov-${LIBPROV_COMMIT}.tar.gz"
S="${WORKDIR}/engine-${PV}"
fi
src_prepare() {
+ cp -R "${WORKDIR}/libprov-${LIBPROV_COMMIT}/." "${S}/libprov" || die
cmake_src_prepare
sed 's:Werror:Wno-error:g' -i "${S}/CMakeLists.txt" || die
}