summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-11-15 23:04:04 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-11-15 23:39:07 +0100
commit5a6d8bdcfbcc596079c5f5cbcd599c92254cc7aa (patch)
tree47f39771db9ba5bfe8a3a3c11b33a854d0c2877c /dev-libs/intel-compute-runtime
parentdev-libs/intel-compute-runtime: drop old version (diff)
downloadgentoo-5a6d8bdcfbcc596079c5f5cbcd599c92254cc7aa.tar.gz
gentoo-5a6d8bdcfbcc596079c5f5cbcd599c92254cc7aa.tar.bz2
gentoo-5a6d8bdcfbcc596079c5f5cbcd599c92254cc7aa.zip
dev-libs/intel-compute-runtime: drop 22.35.24055
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.35.24055.ebuild79
2 files changed, 0 insertions, 80 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 93d1eeb169d8..c061589eb521 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1,2 +1 @@
-DIST intel-compute-runtime-22.35.24055.tar.gz 5710106 BLAKE2B a8efab3ab078b2bc3bc85110fc13f5f68cecd8e9e6978a0f6298d37eb470264303579a66a2bc840b8a8719ef03d67474f4d8959e6bf9442ffb997de1ad1af43b SHA512 c6a238a238647ff79c8ac7a38ebba3e1913f3b6f2ec1adbdde9b8eb9536078de12eac8b35ba45e77eea156b3ec1bd55d8b1279b1fbe729be23429b88de5a757f
DIST intel-compute-runtime-22.39.24347.tar.gz 5774278 BLAKE2B 27a288470f852ec87fae95a946fb87c9850cfc03e99bb869ebd474043d06f8b7beb2873b49d8fe4cc26f7db298c64d7b76d6bda6e6618c1ee8d1a9b658d5f45d SHA512 aef167fd4cc31d32c411ab54cf5f0e5fe13cda7e8fe4eac6aa3f9bf391b7ce9d51033d986d9c5e854c8f1492cce5022463e4b8b0ddc49319ef7bf362435808d5
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.35.24055.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.35.24055.ebuild
deleted file mode 100644
index 20b591b72770..000000000000
--- a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.35.24055.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CMAKE_BUILD_TYPE="Release"
-MY_PN="${PN/intel-/}"
-MY_P="${MY_PN}-${PV}"
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
-HOMEPAGE="https://github.com/intel/compute-runtime"
-SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="+l0 +vaapi"
-
-RDEPEND=">=media-libs/gmmlib-22.1.7:="
-
-DEPEND="
- ${DEPEND}
- >=dev-libs/intel-metrics-library-0_pre20220526:=
- dev-libs/libnl:3
- dev-libs/libxml2:2
- >=dev-util/intel-graphics-compiler-1.0.11485
- >=dev-util/intel-graphics-system-controller-0.8.0:=
- media-libs/mesa
- >=virtual/opencl-3
- l0? ( >=dev-libs/level-zero-1.8.5:= )
- vaapi? (
- x11-libs/libdrm[video_cards_intel]
- media-libs/libva
- )
-"
-
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( "README.md" "FAQ.md" )
-
-PATCHES=( "${FILESDIR}/${PN}-22.24.23453-remove-fortify-sources.patch" )
-
-src_prepare() {
- # Remove '-Werror' from default
- sed -e '/Werror/d' -i CMakeLists.txt || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- # See https://github.com/intel/compute-runtime/issues/531
- filter-flags -flto=* -flto
-
- local mycmakeargs=(
- -DCCACHE_ALLOWED="OFF"
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
- -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
- -DBUILD_WITH_L0="$(usex l0)"
- -DDISABLE_LIBVA="$(usex !vaapi)"
- -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
- -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
- -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
- -DSUPPORT_DG1="ON"
- -Wno-dev
-
- # See https://github.com/intel/intel-graphics-compiler/issues/204
- # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
-
- # If enabled, tests are automatically run during
- # the compile phase and we cannot run them because
- # they require permissions to access the hardware.
- -DSKIP_UNIT_TESTS="1"
- )
-
- cmake_src_configure
-}