summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-11-10 22:16:11 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-11-10 22:20:12 +0000
commit2d461c6e412b92e54452b544703236c4b30b6007 (patch)
tree6e2201ca0e6001596ff30ebfa609d28a81936944 /dev-libs/isl/isl-0.12.2.ebuild
parentecm.eclass: Fix typo (diff)
downloadgentoo-2d461c6e412b92e54452b544703236c4b30b6007.tar.gz
gentoo-2d461c6e412b92e54452b544703236c4b30b6007.tar.bz2
gentoo-2d461c6e412b92e54452b544703236c4b30b6007.zip
dev-libs/isl: restore 0.12.2
Used by cloog-0.18.1. Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-libs/isl/isl-0.12.2.ebuild')
-rw-r--r--dev-libs/isl/isl-0.12.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/isl/isl-0.12.2.ebuild b/dev-libs/isl/isl-0.12.2.ebuild
new file mode 100644
index 000000000000..17e0f4be3378
--- /dev/null
+++ b/dev-libs/isl/isl-0.12.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="A library for manipulating integer points bounded by linear constraints"
+HOMEPAGE="http://isl.gforge.inria.fr/"
+SRC_URI="http://isl.gforge.inria.fr/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0/10"
+KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/gmp-5.1.3-r1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog AUTHORS doc/manual.pdf )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.07-gdb-autoload-dir.patch
+
+ # m4/ax_create_pkgconfig_info.m4 is broken but avoid eautoreconf
+ # https://groups.google.com/group/isl-development/t/37ad876557e50f2c
+ sed -i -e '/Libs:/s:@LDFLAGS@ ::' configure || die #382737
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}