summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-03-16 08:52:12 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-03-16 09:08:04 +0100
commit8959e2031e25edc839296ecd60a53ae4cfd89a39 (patch)
tree752817a22b85d5037e87ef77c11731704d79ff2a /dev-libs/libfilezilla/libfilezilla-0.27.1.ebuild
parentdev-util/howdoi: remove 2.0.8 and 2.0.10 (diff)
downloadgentoo-8959e2031e25edc839296ecd60a53ae4cfd89a39.tar.gz
gentoo-8959e2031e25edc839296ecd60a53ae4cfd89a39.tar.bz2
gentoo-8959e2031e25edc839296ecd60a53ae4cfd89a39.zip
dev-libs/libfilezilla: Bump to version 0.27.1
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libfilezilla/libfilezilla-0.27.1.ebuild')
-rw-r--r--dev-libs/libfilezilla/libfilezilla-0.27.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/libfilezilla/libfilezilla-0.27.1.ebuild b/dev-libs/libfilezilla/libfilezilla-0.27.1.ebuild
new file mode 100644
index 000000000000..f77f65fc8d91
--- /dev/null
+++ b/dev-libs/libfilezilla/libfilezilla-0.27.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="C++ library offering some basic functionality for platform-independent programs"
+HOMEPAGE="https://lib.filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/12" # libfilezilla.so version
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/nettle:0=
+ >=net-libs/gnutls-3.5.7:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_configure() {
+ if use ppc || use arm || use hppa; then
+ # bug 727652
+ append-libs -latomic
+ fi
+
+ default
+}
+
+src_install() {
+ default
+ find "${ED}" -type f \( -name "*.a" -o -name "*.la" \) -delete || die
+}