summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz Tiram <oz.tiram@gmail.com>2023-08-12 08:47:10 +0200
committerSam James <sam@gentoo.org>2023-08-17 07:22:38 +0100
commit7f41445f58469c87e90bfcee6fe25b51ebee23e9 (patch)
tree3d823189d89384fab540f4c2d036fad8c877cfa3 /dev-libs/libmateweather/libmateweather-1.26.1.ebuild
parentmate-extra/caja-extensions: add 1.26.1 (diff)
downloadgentoo-7f41445f58469c87e90bfcee6fe25b51ebee23e9.tar.gz
gentoo-7f41445f58469c87e90bfcee6fe25b51ebee23e9.tar.bz2
gentoo-7f41445f58469c87e90bfcee6fe25b51ebee23e9.zip
dev-libs/libmateweather: add 1.26.1
Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libmateweather/libmateweather-1.26.1.ebuild')
-rw-r--r--dev-libs/libmateweather/libmateweather-1.26.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/libmateweather/libmateweather-1.26.1.ebuild b/dev-libs/libmateweather/libmateweather-1.26.1.ebuild
new file mode 100644
index 000000000000..9989f90f7bc1
--- /dev/null
+++ b/dev-libs/libmateweather/libmateweather-1.26.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE library to access weather information from online services"
+LICENSE="LGPL-2.1+ GPL-2+"
+SLOT="0"
+
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/glib-2.56:2
+ >=dev-libs/libxml2-2.6:2
+ >=net-libs/libsoup-2.54:2.4
+ >=sys-libs/timezone-data-2010k:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --enable-locations-compression \
+ --disable-all-translations-in-one-xml \
+ --disable-icon-update
+}