summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-04-07 19:45:14 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-04-07 19:45:14 +0200
commit91272d43c62f6dfd076cbd0ae98896fdb366e3a5 (patch)
tree417f109af4f66e1a512bbdd4686d1415d1d1411b /dev-libs/mxml
parentgames-fps/eduke32: drop old version (diff)
downloadgentoo-91272d43c62f6dfd076cbd0ae98896fdb366e3a5.tar.gz
gentoo-91272d43c62f6dfd076cbd0ae98896fdb366e3a5.tar.bz2
gentoo-91272d43c62f6dfd076cbd0ae98896fdb366e3a5.zip
dev-libs/mxml: fix compilation with slibtool
Closes: https://bugs.gentoo.org/780060 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/mxml')
-rw-r--r--dev-libs/mxml/files/mxml-3.2-slibtool.patch26
-rw-r--r--dev-libs/mxml/mxml-3.2.ebuild4
2 files changed, 29 insertions, 1 deletions
diff --git a/dev-libs/mxml/files/mxml-3.2-slibtool.patch b/dev-libs/mxml/files/mxml-3.2-slibtool.patch
new file mode 100644
index 000000000000..b5d0df44df7f
--- /dev/null
+++ b/dev-libs/mxml/files/mxml-3.2-slibtool.patch
@@ -0,0 +1,26 @@
+From 4e2e31236f731c0b7e880078269d9f98f595bfd3 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Wed, 7 Apr 2021 09:17:52 -0700
+Subject: [PATCH] build: Don't use libtool.
+
+---
+ Makefile.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 8c05daf..cdc3450 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -52,10 +52,10 @@ BUILDROOT = $(DSTROOT)
+ # Install commands...
+ #
+
+-INSTALL_BIN = $(LIBTOOL) $(INSTALL) -m 755
++INSTALL_BIN = $(INSTALL) -m 755
+ INSTALL_DATA = $(INSTALL) -m 644
+ INSTALL_DIR = $(INSTALL) -d
+-INSTALL_LIB = $(LIBTOOL) $(INSTALL) -m 755
++INSTALL_LIB = $(INSTALL) -m 755
+ INSTALL_MAN = $(INSTALL) -m 644
+ INSTALL_SCRIPT = $(INSTALL) -m 755
+
diff --git a/dev-libs/mxml/mxml-3.2.ebuild b/dev-libs/mxml/mxml-3.2.ebuild
index 710eb09a6790..b21734763a11 100644
--- a/dev-libs/mxml/mxml-3.2.ebuild
+++ b/dev-libs/mxml/mxml-3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,6 +19,8 @@ IUSE="static-libs threads"
BDEPEND="virtual/pkgconfig"
+PATCHES=( "${FILESDIR}/${P}-slibtool.patch" )
+
src_prepare() {
default