summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-09 09:59:03 +0200
committerDavid Seifert <soap@gentoo.org>2022-09-09 09:59:03 +0200
commit7b2cebf22f8a32fc2654e7be03bef0dafa30e59c (patch)
treee7bc1f11693ba5d673504cc0ec990c767fca0c67 /dev-libs/nanomsg
parentdev-libs/log4cpp: drop multilib, static-libs (diff)
downloadgentoo-7b2cebf22f8a32fc2654e7be03bef0dafa30e59c.tar.gz
gentoo-7b2cebf22f8a32fc2654e7be03bef0dafa30e59c.tar.bz2
gentoo-7b2cebf22f8a32fc2654e7be03bef0dafa30e59c.zip
dev-libs/nanomsg: drop multilib
No multilib reverse-dependencies. Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/nanomsg')
-rw-r--r--dev-libs/nanomsg/nanomsg-1.1.5-r1.ebuild (renamed from dev-libs/nanomsg/nanomsg-1.1.5.ebuild)21
1 files changed, 6 insertions, 15 deletions
diff --git a/dev-libs/nanomsg/nanomsg-1.1.5.ebuild b/dev-libs/nanomsg/nanomsg-1.1.5-r1.ebuild
index 43d543afa707..b10243ad377a 100644
--- a/dev-libs/nanomsg/nanomsg-1.1.5.ebuild
+++ b/dev-libs/nanomsg/nanomsg-1.1.5-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake-multilib
+inherit cmake
DESCRIPTION="High-performance messaging interface for distributed applications"
HOMEPAGE="https://nanomsg.org/"
@@ -14,9 +14,9 @@ SLOT="0/5.0.0"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~riscv x86"
IUSE="doc"
-DEPEND="doc? ( dev-ruby/asciidoctor )"
+BDEPEND="doc? ( dev-ruby/asciidoctor )"
-multilib_src_prepare() {
+src_prepare() {
# Old CPUs like HPPA fails test because of timeout
sed -i \
-e '/inproc_shutdown/s/5/80/' \
@@ -26,20 +26,11 @@ multilib_src_prepare() {
cmake_src_prepare
}
-multilib_src_configure() {
+src_configure() {
local mycmakeargs=(
-DNN_STATIC_LIB=OFF
+ -DNN_ENABLE_DOC=$(usex doc)
)
- if multilib_is_native_abi; then
- mycmakeargs+=(
- -DNN_ENABLE_DOC=$(usex doc ON OFF)
- )
- else
- mycmakeargs+=(
- -DNN_ENABLE_DOC=OFF
- -DNN_TOOLS=OFF
- -DNN_ENABLE_NANOCAT=OFF
- )
- fi
+
cmake_src_configure
}