summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-06-02 19:10:46 -0400
committerTim Harder <radhermit@gentoo.org>2017-06-02 19:11:28 -0400
commita3c1e85a39bf1207464048d4098c7307a6bc49a6 (patch)
tree9afc41e6028968d2aa70db4485d937342e817d07 /dev-libs/npth/npth-1.5.ebuild
parentwww-apps/owncloud: drop unsupported 8.2 (diff)
downloadgentoo-a3c1e85a39bf1207464048d4098c7307a6bc49a6.tar.gz
gentoo-a3c1e85a39bf1207464048d4098c7307a6bc49a6.tar.bz2
gentoo-a3c1e85a39bf1207464048d4098c7307a6bc49a6.zip
dev-libs/npth: version bump to 1.5
Diffstat (limited to 'dev-libs/npth/npth-1.5.ebuild')
-rw-r--r--dev-libs/npth/npth-1.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/npth/npth-1.5.ebuild b/dev-libs/npth/npth-1.5.ebuild
new file mode 100644
index 000000000000..e5f5eb0839ce
--- /dev/null
+++ b/dev-libs/npth/npth-1.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit libtool ltprune
+
+DESCRIPTION="New GNU Portable Threads Library"
+HOMEPAGE="https://git.gnupg.org/cgi-bin/gitweb.cgi?p=npth.git"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ elibtoolize # for Solaris shared library
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}