summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2023-10-09 12:23:26 +0000
committerPatrick Lauer <patrick@gentoo.org>2023-10-09 12:33:38 +0000
commitd21312a75af1306130ba89803db0ff0b1d60f057 (patch)
tree219a20de4926cb97664e32abe7e220ac612052b1 /dev-libs/roct-thunk-interface
parentdev-util/rocm-cmake: add 5.7.0 (diff)
downloadgentoo-d21312a75af1306130ba89803db0ff0b1d60f057.tar.gz
gentoo-d21312a75af1306130ba89803db0ff0b1d60f057.tar.bz2
gentoo-d21312a75af1306130ba89803db0ff0b1d60f057.zip
dev-libs/roct-thunk-interface: add 5.7.0
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-libs/roct-thunk-interface')
-rw-r--r--dev-libs/roct-thunk-interface/Manifest1
-rw-r--r--dev-libs/roct-thunk-interface/files/roct-thunk-interface-5.7.0-functions.patch12
-rw-r--r--dev-libs/roct-thunk-interface/roct-thunk-interface-5.7.0.ebuild42
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/roct-thunk-interface/Manifest b/dev-libs/roct-thunk-interface/Manifest
index 3761fdba2045..ca5676280792 100644
--- a/dev-libs/roct-thunk-interface/Manifest
+++ b/dev-libs/roct-thunk-interface/Manifest
@@ -2,3 +2,4 @@ DIST roct-thunk-interface-5.1.3.tar.gz 3178689 BLAKE2B c46af7bc60772beaa9a214a86
DIST roct-thunk-interface-5.3.3.tar.gz 646773 BLAKE2B 48632cad576ceccede0ee62663f226cbedba8374d8962028fd729a7b8e7eb75bebcb2f8ce06a838de15a388caea3d6dcb150db80f8d45a91675997b4f80625e6 SHA512 4a8730d16a0d240a43d5e22092325b0731d133733af0aac6c6893763d1ffb1a04a0c045d988835079581e097fc7c9e383f41ba84daa105c032d3a653b6b2c6b0
DIST roct-thunk-interface-5.4.3.tar.gz 648897 BLAKE2B 9eefc5f417280a98c7c6b6d611d0d87fa52abca94f67bf5ecc10d84bb86433b5ff502f76aa6724245c7cf9d82b5c16c10943275e8d41f0053484765df5a901db SHA512 1787526515ec708edc398cdba308a8dfa32c2579524a6856a6f336cb7bfee8f9a00d67f1b489993c7454d1d88885032ce85ac752b4a15aaedef910f147aed3b5
DIST roct-thunk-interface-5.5.1.tar.gz 649617 BLAKE2B 54ecae486e5d8b99363947a93b38bb80f6b129bbacc1b3152d58e44cf093e44254075cdc49f6d0f474a04c5e2a1f3945399a744892ac1e5c1fb3ff38fd02370c SHA512 359ce5c7d8fce1f6100aac236efd24d35ce8098732bf89225e7c07a4731452388b5213eda8767a8d7723afa2041033bbcb287dcb00e88a0df9494acf70f8ebaf
+DIST roct-thunk-interface-5.7.0.tar.gz 665525 BLAKE2B 7b89848b386f2c766bc45583cb4a004bd093d54ef99263d9a75bae6e7477cb50371906943c935a1525489b368c649b467bf0e02e71aa3c3f31166f52233a1655 SHA512 8b975e0ff902cad1bf5365da45c694e5c74d3f289a729b62de59c651028657de468abea414cb6aee8fc2c82f59eccae6cbb70ecde5f9d409c82974207e0ee784
diff --git a/dev-libs/roct-thunk-interface/files/roct-thunk-interface-5.7.0-functions.patch b/dev-libs/roct-thunk-interface/files/roct-thunk-interface-5.7.0-functions.patch
new file mode 100644
index 000000000000..f9a573debc68
--- /dev/null
+++ b/dev-libs/roct-thunk-interface/files/roct-thunk-interface-5.7.0-functions.patch
@@ -0,0 +1,12 @@
+diff --git a/src/libhsakmt.ver b/src/libhsakmt.ver
+index dc17215..10c840c 100644
+--- a/src/libhsakmt.ver
++++ b/src/libhsakmt.ver
+@@ -75,6 +75,7 @@ hsaKmtSetXNACKMode;
+ hsaKmtGetXNACKMode;
+ hsaKmtOpenSMI;
+ hsaKmtExportDMABufHandle;
++hsaKmtWaitOnMultipleEvents_Ext;
+
+ local: *;
+ };
diff --git a/dev-libs/roct-thunk-interface/roct-thunk-interface-5.7.0.ebuild b/dev-libs/roct-thunk-interface/roct-thunk-interface-5.7.0.ebuild
new file mode 100644
index 000000000000..3750eab247b5
--- /dev/null
+++ b/dev-libs/roct-thunk-interface/roct-thunk-interface-5.7.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake linux-info
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCT-Thunk-Interface-rocm-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Radeon Open Compute Thunk Interface"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface"
+CONFIG_CHECK="~HSA_AMD ~HMM_MIRROR ~ZONE_DEVICE ~DRM_AMDGPU ~DRM_AMDGPU_USERPTR"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="sys-process/numactl"
+DEPEND="${RDEPEND}"
+BDEPEND="x11-libs/libdrm[video_cards_amdgpu]"
+
+CMAKE_BUILD_TYPE=Release
+
+PATCHES=( "${FILESDIR}/${P}-functions.patch" )
+
+src_prepare() {
+ sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
+ sed -e "s:ubuntu:gentoo:" -i CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCPACK_PACKAGING_INSTALL_PREFIX="${EPREFIX}/usr"
+ )
+ cmake_src_configure
+}