summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-08-23 21:57:30 +0100
committerMarek Szuba <marecki@gentoo.org>2023-08-23 22:05:51 +0100
commit85f96685aa2e5b7cf8f7d71b973cc68181830d81 (patch)
treed49c9e5e83dc75c26989b3a3e4f90c5f9f43b437 /dev-libs/sentry-native/sentry-native-0.6.5-r1.ebuild
parentmail-mta/proton-mail-bridge: remove IUSE=gui from 3.1.3 (diff)
downloadgentoo-85f96685aa2e5b7cf8f7d71b973cc68181830d81.tar.gz
gentoo-85f96685aa2e5b7cf8f7d71b973cc68181830d81.tar.bz2
gentoo-85f96685aa2e5b7cf8f7d71b973cc68181830d81.zip
dev-libs/sentry-native: make installed cmake modules handle USE=breakpad
Looks like upstream has only tested this for bundled breakpad. Closes: https://bugs.gentoo.org/912886 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-libs/sentry-native/sentry-native-0.6.5-r1.ebuild')
-rw-r--r--dev-libs/sentry-native/sentry-native-0.6.5-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/sentry-native/sentry-native-0.6.5-r1.ebuild b/dev-libs/sentry-native/sentry-native-0.6.5-r1.ebuild
new file mode 100644
index 000000000000..1e3a691a642a
--- /dev/null
+++ b/dev-libs/sentry-native/sentry-native-0.6.5-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Sentry SDK for C, C++ and native applications"
+HOMEPAGE="https://sentry.io/ https://github.com/getsentry/sentry-native"
+SRC_URI="https://github.com/getsentry/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+breakpad +curl test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ breakpad? (
+ dev-util/breakpad
+ virtual/pkgconfig
+ )
+ curl? ( net-misc/curl )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.5_cmake-breakpad.patch
+ "${FILESDIR}"/${PN}-0.6.5_no-fuzz-test.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DSENTRY_BUILD_EXAMPLES=OFF
+ -DSENTRY_BACKEND=$(usex breakpad "breakpad" "inproc")
+ -DSENTRY_BUILD_TESTS=$(usex test)
+ -DSENTRY_TRANSPORT=$(usex curl "curl" "none")
+ )
+ # Avoid "not used by the project" warnings when USE=-breakpad
+ if use breakpad; then
+ mycmakeargs+=( -DSENTRY_BREAKPAD_SYSTEM=ON )
+ fi
+
+ cmake_src_configure
+}