summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-08 07:17:06 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-03-08 07:28:17 -0500
commit44d553ed0237c6542f39ebf6a5e84c373cf7e176 (patch)
tree60b0a8c06ffb49e47bd51853abdd213ba7af1335 /dev-libs/simde
parentx11-apps/luit: Stabilize 20240102 sparc, #926494 (diff)
downloadgentoo-44d553ed0237c6542f39ebf6a5e84c373cf7e176.tar.gz
gentoo-44d553ed0237c6542f39ebf6a5e84c373cf7e176.tar.bz2
gentoo-44d553ed0237c6542f39ebf6a5e84c373cf7e176.zip
dev-libs/simde: fix building tests with musl
Needs a revbump given this modifies an installed header which otherwise could lead to revdeps failing to build with musl rather than tests. On top of now building, the tests passes fine (llvm-musl). Closes: https://bugs.gentoo.org/926488 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-libs/simde')
-rw-r--r--dev-libs/simde/files/simde-0.7.6-musl.patch18
-rw-r--r--dev-libs/simde/simde-0.7.6-r1.ebuild (renamed from dev-libs/simde/simde-0.7.6.ebuild)4
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/simde/files/simde-0.7.6-musl.patch b/dev-libs/simde/files/simde-0.7.6-musl.patch
new file mode 100644
index 000000000000..c070f858ea81
--- /dev/null
+++ b/dev-libs/simde/files/simde-0.7.6-musl.patch
@@ -0,0 +1,18 @@
+This workaround patch should be removable when musl implements C23
+functions (technically this isn't a __GLIBC__-only quirk, but used
+due to lack of anything better beside running a build test for it).
+
+https://bugs.gentoo.org/926488
+https://github.com/simd-everywhere/simde/issues/1001
+--- a/simde/simde-math.h
++++ b/simde/simde-math.h
+@@ -1182,3 +1182,3 @@
+ #if \
+- (!defined(HEDLEY_EMSCRIPTEN_VERSION) && HEDLEY_HAS_BUILTIN(__builtin_roundeven)) || \
++ (defined (__GLIBC__) && !defined(HEDLEY_EMSCRIPTEN_VERSION) && HEDLEY_HAS_BUILTIN(__builtin_roundeven)) || \
+ HEDLEY_GCC_VERSION_CHECK(10,0,0)
+@@ -1202,3 +1202,3 @@
+ #if \
+- (!defined(HEDLEY_EMSCRIPTEN_VERSION) && HEDLEY_HAS_BUILTIN(__builtin_roundevenf)) || \
++ (defined(__GLIBC__) && !defined(HEDLEY_EMSCRIPTEN_VERSION) && HEDLEY_HAS_BUILTIN(__builtin_roundevenf)) || \
+ HEDLEY_GCC_VERSION_CHECK(10,0,0)
diff --git a/dev-libs/simde/simde-0.7.6.ebuild b/dev-libs/simde/simde-0.7.6-r1.ebuild
index 8d8a8be32a7a..2a963a57dd1e 100644
--- a/dev-libs/simde/simde-0.7.6.ebuild
+++ b/dev-libs/simde/simde-0.7.6-r1.ebuild
@@ -18,6 +18,10 @@ KEYWORDS="~amd64 ~arm64"
IUSE="test"
RESTRICT="!test? ( test )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.6-musl.patch
+)
+
src_configure() {
# *FLAGS are only used for tests (nothing that is installed), and
# upstream tests with specific *FLAGS and is otherwise flaky with