summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-02-02 16:15:46 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-02-02 16:15:46 +0200
commit355d9edae2af516fa32340e681b92e368ccc9e4e (patch)
treeaa1826e397e9079a6b7acaed0c747d80b648044c /dev-libs/tinyxml2
parentsci-geosciences/qmapshack: Stabilize 1.17.1 amd64, #923535 (diff)
downloadgentoo-355d9edae2af516fa32340e681b92e368ccc9e4e.tar.gz
gentoo-355d9edae2af516fa32340e681b92e368ccc9e4e.tar.bz2
gentoo-355d9edae2af516fa32340e681b92e368ccc9e4e.zip
dev-libs/tinyxml2: add 10.0.0
I've also dropped old inaccessible website. We remain with the github one. Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-libs/tinyxml2')
-rw-r--r--dev-libs/tinyxml2/Manifest1
-rw-r--r--dev-libs/tinyxml2/tinyxml2-10.0.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/tinyxml2/Manifest b/dev-libs/tinyxml2/Manifest
index ad78643036ad..22114c122de1 100644
--- a/dev-libs/tinyxml2/Manifest
+++ b/dev-libs/tinyxml2/Manifest
@@ -1 +1,2 @@
+DIST tinyxml2-10.0.0.tar.gz 642421 BLAKE2B 89f5a9d92e4e3f12f4abcdbabb2d4cb25950a044bc6f6f788a1a6291913e77d82a805438aacf1e6c14dd8977aa3930527c89ef066e2075161f176a301cbf1b3f SHA512 a359d33bc12fad455b53d81011dbe12727cae0aabfaa5704f1a25807ca216dd854a571291029886c0beedeca5c3b6393dd49c4718773e18a0e008abbdb3de36a
DIST tinyxml2-9.0.0.tar.gz 619734 BLAKE2B 9a7bb8b8158417aa505e3d9fcc246b0bede52d6d4d5ff1b5cee891c2b72d1ee43d00ccea001ac24500f52c36320994b3446f3898ab2be1997940dbff526bc78e SHA512 9c5ce8131984690df302ca3e32314573b137180ed522c92fd631692979c942372a28f697fdb3d5e56bcf2d3dc596262b724d088153f3e1d721c9536f2a883367
diff --git a/dev-libs/tinyxml2/tinyxml2-10.0.0.ebuild b/dev-libs/tinyxml2/tinyxml2-10.0.0.ebuild
new file mode 100644
index 000000000000..d75506b37166
--- /dev/null
+++ b/dev-libs/tinyxml2/tinyxml2-10.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# No meson because of bug #791163
+inherit cmake
+
+DESCRIPTION="A simple, small, efficient, C++ XML parser"
+HOMEPAGE="https://github.com/leethomason/tinyxml2/"
+SRC_URI="https://github.com/leethomason/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/10"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}