summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro@users.noreply.github.com>2023-04-14 19:54:21 -0400
committerSam James <sam@gentoo.org>2023-04-15 03:17:09 +0100
commit12faf25bcfc6a5d8419ed0b0024c31cd2f55b5cc (patch)
tree0d117d412334d679346226693c9abf5c1354404b /dev-libs/tlsh
parentmedia-gfx/graphviz: Stabilize 7.1.0 sparc, #904345 (diff)
downloadgentoo-12faf25bcfc6a5d8419ed0b0024c31cd2f55b5cc.tar.gz
gentoo-12faf25bcfc6a5d8419ed0b0024c31cd2f55b5cc.tar.bz2
gentoo-12faf25bcfc6a5d8419ed0b0024c31cd2f55b5cc.zip
dev-libs/tlsh: add big-endian fix
See: https://github.com/trendmicro/tlsh/issues/131 Bug: https://bugs.gentoo.org/861710 Signed-off-by: Matoro Mahri <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/tlsh')
-rw-r--r--dev-libs/tlsh/tlsh-4.8.2.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-libs/tlsh/tlsh-4.8.2.ebuild b/dev-libs/tlsh/tlsh-4.8.2.ebuild
index dc63ec1c565a..8b6e02c5e549 100644
--- a/dev-libs/tlsh/tlsh-4.8.2.ebuild
+++ b/dev-libs/tlsh/tlsh-4.8.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
CMAKE_IN_SOURCE_BUILD=1
-inherit cmake
+inherit cmake toolchain-funcs flag-o-matic
DESCRIPTION="Fuzzy matching library"
HOMEPAGE="https://github.com/trendmicro/tlsh"
@@ -19,6 +19,12 @@ PATCHES=(
"${FILESDIR}"/${P}-respect-flags.patch
)
+src_prepare() {
+ # https://github.com/trendmicro/tlsh/issues/131
+ [[ "$(tc-endian)" == "big" ]] && append-flags "-D__SPARC"
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DTLSH_CHECKSUM_1B=1