summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-11 07:16:18 +0000
committerSam James <sam@gentoo.org>2024-11-11 07:16:18 +0000
commit00eafa870ff52b273da29e60d1e60e31018b39e9 (patch)
tree7864a6ffcbf4bec26fdd3e5e41d55a09ee30531a /dev-libs
parentgames-simulation/openttd: add 14.1 (diff)
downloadgentoo-00eafa870ff52b273da29e60d1e60e31018b39e9.tar.gz
gentoo-00eafa870ff52b273da29e60d1e60e31018b39e9.tar.bz2
gentoo-00eafa870ff52b273da29e60d1e60e31018b39e9.zip
dev-libs/icu-le-hb: add 2.0.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/icu-le-hb/Manifest1
-rw-r--r--dev-libs/icu-le-hb/icu-le-hb-2.0.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/icu-le-hb/Manifest b/dev-libs/icu-le-hb/Manifest
index 3c7d06f31db3..500dd55654ad 100644
--- a/dev-libs/icu-le-hb/Manifest
+++ b/dev-libs/icu-le-hb/Manifest
@@ -1 +1,2 @@
DIST icu-le-hb-1.2.3.tar.gz 45191 BLAKE2B 14ad8592a27ff8673d9609a689bedf5094c127bb9cb638a1e65c1fcb6e22e8c488f89e55af5578cd4961a34feafffd5df9cdedb20dfc7edcc4d6f63aec1eff0f SHA512 c1450e28c1984a409cacc2b675ab91fa0e80edfbbfb201913cb83e435fd30f3a3ad78ca32f8cf092c5f056f2812b899ceb4471b36ef975faf5be892d305a1efd
+DIST icu-le-hb-2.0.0.tar.gz 421450 BLAKE2B 20b72590ff5b968754ab369f57770c449fa68e001c9211987adf708447a6ee956266b1fa64049651b2b132afcb98f9c456d3549e48db5d8d40faa0ec90cd801d SHA512 aa8d822ef3c471a8e4325a8f4bc01011e096b7fcc0c7cbab3849f91bda6b802397c831e8db34525ebaa2b14e2a007a5728af92e75f0605d944973984c2ceec28
diff --git a/dev-libs/icu-le-hb/icu-le-hb-2.0.0.ebuild b/dev-libs/icu-le-hb/icu-le-hb-2.0.0.ebuild
new file mode 100644
index 000000000000..ac7bf9a5f380
--- /dev/null
+++ b/dev-libs/icu-le-hb/icu-le-hb-2.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="ICU Layout Engine API on top of HarfBuzz shaping library"
+HOMEPAGE="https://github.com/harfbuzz/harfbuzz https://github.com/harfbuzz/icu-le-hb"
+SRC_URI="https://github.com/harfbuzz/icu-le-hb/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="icu"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+# dev-libs/icu is not linked into icu-le-hb but the latter still needs
+# to be rebuilt on dev-libs/icu upgrades (see bug #621786).
+RDEPEND="
+ dev-libs/icu:=[${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-2.0.0:=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name "*.la" -delete || die
+}