summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2022-02-19 21:28:14 +0100
committerFabian Groffen <grobian@gentoo.org>2022-02-19 21:28:29 +0100
commit24d2bd2281b6adac7f71b4528faaf9a5a6a9b977 (patch)
tree92c1267fed973a0df834b7ea5e710c77f6d4d556 /dev-libs
parentapp-editors/gedit-plugins: Version bump to 41.0 (diff)
downloadgentoo-24d2bd2281b6adac7f71b4528faaf9a5a6a9b977.tar.gz
gentoo-24d2bd2281b6adac7f71b4528faaf9a5a6a9b977.tar.bz2
gentoo-24d2bd2281b6adac7f71b4528faaf9a5a6a9b977.zip
dev-libs/gnulib-2022.02.12.16.27.05: version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gnulib/Manifest1
-rw-r--r--dev-libs/gnulib/gnulib-2022.02.12.16.27.05.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/gnulib/Manifest b/dev-libs/gnulib/Manifest
index 39d4a175c2a9..8bab6140bab1 100644
--- a/dev-libs/gnulib/Manifest
+++ b/dev-libs/gnulib/Manifest
@@ -1 +1,2 @@
+DIST gnulib-9f48fb992a3d7e96610c4ce8be969cff2d61a01b.tar.gz 7637646 BLAKE2B 80a2e5fba2c5d75903dec43eb663d4f354c55317efe2f0c0e5b53bcff3ff17d17ade605a1219550a025335cfa75eba8e6b38af01ecfdf989de7741a36cc37d4e SHA512 db786cd38eb5deb77a6c189ebd8425618a6281c7129355011295517020cb57982f0d568dc0f77bbf2bb709e6e05c729e0ec50351fd7951909723173fe89ccd26
DIST gnulib-b451121ab45497e78cb6f612c8673a9705193391.tar.gz 6666079 BLAKE2B e7d3b9478697067b57ab198e044f3c854128d5fe390d30947829ce4f34c695a748668c33ae19690e9927fff6df3e194a3160cb4adb7cf47235c603241c66889a SHA512 f6e165cfc0a3999c778d9f43ffc90ff9b569a77ff1e54ff5c50b12b0eddf262c24da8cd2719548574e0397535bb0eb835eef603cc74769f7876ef9db101bebec
diff --git a/dev-libs/gnulib/gnulib-2022.02.12.16.27.05.ebuild b/dev-libs/gnulib/gnulib-2022.02.12.16.27.05.ebuild
new file mode 100644
index 000000000000..302bd8f7f895
--- /dev/null
+++ b/dev-libs/gnulib/gnulib-2022.02.12.16.27.05.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GIT_TAG="9f48fb992a3d7e96610c4ce8be969cff2d61a01b"
+
+DESCRIPTION="Library of common routines intended to be shared"
+HOMEPAGE="https://www.gnu.org/software/gnulib"
+SRC_URI="https://git.savannah.gnu.org/cgit/${PN}.git/snapshot/${PN}-${GIT_TAG}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+S="${WORKDIR}/${PN}-${GIT_TAG}"
+
+src_compile() {
+ if use doc; then
+ emake -C doc info html
+ fi
+}
+
+src_install() {
+ dodoc README ChangeLog
+
+ insinto /usr/share/${PN}
+ doins -r build-aux
+ doins -r doc
+ doins -r lib
+ doins -r m4
+ doins -r modules
+ doins -r tests
+ doins -r top
+
+ # install the real script
+ exeinto /usr/share/${PN}
+ doexe gnulib-tool
+
+ # create and install the wrapper
+ dosym ../share/${PN}/gnulib-tool /usr/bin/gnulib-tool
+}