summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-23 17:24:40 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-23 17:24:40 -0400
commit5a3269ea24eb26fbec3b6bb29ab89f9ecb1b3642 (patch)
tree2a0dd5f574c660e29fd01c4fc8291ea7e286516d /dev-libs
parentapp-text/odt2txt: amd64 stable wrt bug #656164 (diff)
downloadgentoo-5a3269ea24eb26fbec3b6bb29ab89f9ecb1b3642.tar.gz
gentoo-5a3269ea24eb26fbec3b6bb29ab89f9ecb1b3642.tar.bz2
gentoo-5a3269ea24eb26fbec3b6bb29ab89f9ecb1b3642.zip
dev-libs/libreport: bump
Closes: https://bugs.gentoo.org/467726 Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libreport/Manifest1
-rw-r--r--dev-libs/libreport/libreport-2.9.5.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-libs/libreport/Manifest b/dev-libs/libreport/Manifest
index 109cc1378f46..40bdba4ed1d3 100644
--- a/dev-libs/libreport/Manifest
+++ b/dev-libs/libreport/Manifest
@@ -1 +1,2 @@
DIST libreport-2.0.13.tar.gz 1190147 BLAKE2B fe79d924fbf7bd11cc3fd23956a137fb296baf9c40f12f3ecfefe68c82281f62299887511a096196b4fdcdc9245ab268592dace4e728c2c34af47581e52f5132 SHA512 cfe963db8091b245f8ceb7d8501466f4f9464c28d298faeafc9f6e57deafdfdc6501d468bf5ffd83703adb67bc1e05e06c56b5c0e0028bb2e0134788ddbb2181
+DIST libreport-2.9.5.tar.gz 2271742 BLAKE2B e74d694c0012e984aab8044e99fee8e12a197c0a2edb933e78f045260043d40557509056b1093bc13cbe983976d5525cde1f7596a942760df10c857e99d6b56e SHA512 f207710d88f39870d08e3a5fdfa3e1d5a808625bd36b1dcce363cefd39e582bad6be6dc4224db5e1df4404734c3dd69c437c377303fe978ae21b608fceb833ce
diff --git a/dev-libs/libreport/libreport-2.9.5.ebuild b/dev-libs/libreport/libreport-2.9.5.ebuild
new file mode 100644
index 000000000000..fab10399795b
--- /dev/null
+++ b/dev-libs/libreport/libreport-2.9.5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit autotools ltprune python-r1 user
+
+DESCRIPTION="Generic library for reporting software bugs"
+HOMEPAGE="https://github.com/abrt/libreport"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+gtk python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ app-admin/augeas
+ >=dev-libs/glib-2.43:2
+ dev-libs/satyr
+ dev-libs/json-c:=
+ dev-libs/libtar
+ dev-libs/libxml2:2
+ dev-libs/newt:=
+ dev-libs/xmlrpc-c:=
+ net-libs/libproxy:=
+ net-misc/curl:=[ssl]
+ sys-apps/dbus
+ gtk? ( >=x11-libs/gtk+-3.3.12:3 )
+ python? ( ${PYTHON_DEPS} )
+ x11-misc/xdg-utils
+"
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.3.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+# Tests require python-meh, which is highly redhat-specific.
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup abrt
+ enewuser abrt -1 -1 -1 abrt
+}
+
+src_prepare() {
+ default
+ ./gen-version || die # Needed to be run before autoreconf
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ local myargs=(
+ --localstatedir="${EPREFIX}/var"
+ --without-bugzilla
+ # Fixes "syntax error in VERSION script" and we aren't supporting Python2 anyway
+ --without-python2
+ $(usex python "--with-python3" "--without-python3")
+ )
+
+ econf "${myargs[@]}"
+}
+
+src_install() {
+
+ # Need to set correct ownership for use by app-admin/abrt
+ diropts -o abrt -g abrt
+ keepdir /var/spool/abrt
+
+ prune_libtool_files --modules
+}