summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2024-05-28 16:14:01 +0000
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 21:09:50 +0200
commit9f6b1881f36bc7d0e070fb16a149257bace9f9ec (patch)
treed94ef417765b56931f61db3b3c356c7aa4cd5e18 /dev-libs
parentmedia-plugins/vdr-dvdswitch: update HOMEPAGE, SRC_URI (diff)
downloadgentoo-9f6b1881f36bc7d0e070fb16a149257bace9f9ec.tar.gz
gentoo-9f6b1881f36bc7d0e070fb16a149257bace9f9ec.tar.bz2
gentoo-9f6b1881f36bc7d0e070fb16a149257bace9f9ec.zip
dev-libs/boxfort: enable py3.12
Bug: https://bugs.gentoo.org/929406 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boxfort/boxfort-0.1.4-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/boxfort/boxfort-0.1.4-r1.ebuild b/dev-libs/boxfort/boxfort-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..c9e74c1383af
--- /dev/null
+++ b/dev-libs/boxfort/boxfort-0.1.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="Convenient & cross-platform sandboxing C library"
+HOMEPAGE="https://github.com/Snaipe/BoxFort"
+SRC_URI="https://github.com/Snaipe/BoxFort/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/BoxFort-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-alpha ~amd64 ~arm ~arm64 -hppa -ia64 -loong -m68k -mips -ppc -ppc64 -riscv -s390 -sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? (
+ $(python_gen_any_dep 'dev-util/cram[${PYTHON_USEDEP}]')
+ )"
+BDEPEND="virtual/pkgconfig"
+
+python_check_deps() {
+ use test && has_version "dev-util/cram[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test samples)
+ $(meson_use test tests)
+ )
+
+ meson_src_configure
+}