summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-10-14 22:11:44 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-10-14 22:12:06 +0200
commitd2dcc8ff49aed6296b73df44a08fbc6be0447525 (patch)
tree38211192a2a777e946220b937a6c8a8c19f8dc71 /dev-ml/camlp4
parentdev-util/editorconfig-geany: add 0.2.1 (diff)
downloadgentoo-d2dcc8ff49aed6296b73df44a08fbc6be0447525.tar.gz
gentoo-d2dcc8ff49aed6296b73df44a08fbc6be0447525.tar.bz2
gentoo-d2dcc8ff49aed6296b73df44a08fbc6be0447525.zip
dev-ml/camlp4: add 5.2_p1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/camlp4')
-rw-r--r--dev-ml/camlp4/Manifest1
-rw-r--r--dev-ml/camlp4/camlp4-5.2_p1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-ml/camlp4/Manifest b/dev-ml/camlp4/Manifest
index 7e9cdebe2194..4f3667862fe4 100644
--- a/dev-ml/camlp4/Manifest
+++ b/dev-ml/camlp4/Manifest
@@ -4,3 +4,4 @@ DIST camlp4-4.11_p1.tar.gz 650280 BLAKE2B 6fe46b49c1f2b2e5fc87fbbbdba3ccae795c55
DIST camlp4-4.12.tar.gz 650428 BLAKE2B 4957d3db73ec82fbac58dd95fa13c48f9f8480a70cd6bded43a00df0a182f9b9e31a43acef8264f9d940776667d10b0a5c46bded59ebf4a645719264628428fc SHA512 0a19bb596e47076a28a6bea62007f1d3b59c4d688075f6b723abaa205c555707feb4ea0624259994a4ba5251fdea9dc61cdc936dc13611b36937e755a4bc9b7b
DIST camlp4-4.13.tar.gz 650642 BLAKE2B 5bf70b21f47eefe4631227d0d30fdd08ab965020026d0183fc94b9dbfd1eee45626afbe62bf9507b1a887217cf9245901d40f25cce9430155eb9ec1ddc577554 SHA512 d3307bd11b813540d126719c0afe7e75a7740d0851b272be9bd1a28e8b1ab1ed9a7576109000c8d6cee7ece7f777122aa83917a48147d42ed8f4d72994397819
DIST camlp4-4.14_p1.tar.gz 641790 BLAKE2B 3e1054a924956e9c23d43fb4ef00cf99fe09f6d2a5eb4216cb3d5079a439159d36703b6ae268789d73e51e87ed0329531b25c2e846df03c4ae99b1a6403b84c3 SHA512 1853ae0465a1366cf73d7aa9de56c037ef3d4bb5b341fe3eeb39677b5b08bda44316634b93d5d35d917a98dff8eb40da974937f714ab609818e7d25f716de811
+DIST camlp4-5.2_p1.tar.gz 653548 BLAKE2B 27002802bbf0d0a67d5c2c967fa54d72087c9b08020d290ec081545ef4d4c7bea794ab8ea74608d63ed4a51b58fe44a1ac921d4de9f66f754a7b3d931e5ed818 SHA512 7034cf32575b6a7dc0406fea3c354068598195aa84a75e8576ea1219c38e4bffdc048c936d440bab235aea76510972a174bffba13f4f94f531b80fb4d80ca4ad
diff --git a/dev-ml/camlp4/camlp4-5.2_p1.ebuild b/dev-ml/camlp4/camlp4-5.2_p1.ebuild
new file mode 100644
index 000000000000..e7445e57932a
--- /dev/null
+++ b/dev-ml/camlp4/camlp4-5.2_p1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV=${PV/_p/+}
+MY_P=${PN}-${MY_PV}
+
+inherit edo
+
+DESCRIPTION="System for writing extensible parsers for programming languages"
+HOMEPAGE="https://github.com/camlp4/camlp4"
+SRC_URI="https://github.com/camlp4/camlp4/archive/${MY_PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${P/_p/-}
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ =dev-lang/ocaml-5.2*:=[ocamlopt?]
+ dev-ml/camlp-streams:=[ocamlopt?]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-ml/ocamlbuild[ocamlopt?]
+ dev-ml/findlib:=
+"
+
+QA_FLAGS_IGNORED='.*'
+
+PATCHES=( "${FILESDIR}/reload.patch" )
+
+src_configure() {
+ edo ./configure \
+ --bindir="${EPREFIX}/usr/bin" \
+ --libdir="$(ocamlc -where)" \
+ --pkgdir="$(ocamlc -where)"
+}
+
+src_compile() {
+ # Increase stack limit to 11GiB to avoid stack overflow error.
+ ulimit -s 11530000
+
+ emake byte
+ use ocamlopt && emake native
+}
+
+src_install() {
+ # OCaml generates textrels on 32-bit arches
+ if use arm || use ppc || use x86 ; then
+ export QA_TEXTRELS='.*'
+ fi
+ emake DESTDIR="${D}" install install-META
+ dodoc CHANGES.md README.md
+}