summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-17 09:31:24 +0000
committerSam James <sam@gentoo.org>2020-10-17 09:32:10 +0000
commit73f875a137b7a36b013bd2e3ff7f062738e29496 (patch)
treef2df6f1e75d4afd71d008ddc329e916633741b58 /dev-ml/ocamlgraph/ocamlgraph-1.8.7.ebuild
parentnet-p2p/mldonkey: add subslot deps (diff)
downloadgentoo-73f875a137b7a36b013bd2e3ff7f062738e29496.tar.gz
gentoo-73f875a137b7a36b013bd2e3ff7f062738e29496.tar.bz2
gentoo-73f875a137b7a36b013bd2e3ff7f062738e29496.zip
dev-ml/ocamlgraph: fix MissingUseDepDefault
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/ocamlgraph/ocamlgraph-1.8.7.ebuild')
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-1.8.7.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-ml/ocamlgraph/ocamlgraph-1.8.7.ebuild b/dev-ml/ocamlgraph/ocamlgraph-1.8.7.ebuild
deleted file mode 100644
index 09d0810bef2b..000000000000
--- a/dev-ml/ocamlgraph/ocamlgraph-1.8.7.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit findlib eutils
-
-DESCRIPTION="O'Caml Graph library"
-HOMEPAGE="http://ocamlgraph.lri.fr/index.en.html"
-SRC_URI="http://ocamlgraph.lri.fr/download/${P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~arm64 ppc x86"
-RDEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
- gtk? ( dev-ml/lablgtk:=[gnomecanvas,ocamlopt?] )"
-DEPEND="${RDEPEND}
- doc? ( dev-tex/hevea dev-ml/ocamlweb )"
-IUSE="doc examples gtk +ocamlopt"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-1.8.6-installfindlib.patch"
- epatch "${FILESDIR}/${P}-test.patch"
-}
-
-src_compile() {
- emake byte
- use ocamlopt && emake opt
-
- if use doc; then
- emake doc
- fi
-
- if use gtk; then
- emake OCAMLBEST=$(usex ocamlopt opt byte) viewer dgraph editor
- fi
-}
-
-src_install() {
- findlib_src_preinst
- use ocamlopt || export WANT_OCAMLOPT=no
- use gtk && export WANT_GTK=yes
- emake install-findlib
-
- if use gtk ; then
- local ext=byte
- use ocamlopt && ext=opt
- newbin dgraph/dgraph.${ext} ${PN}-dgraph
- newbin editor/editor.${ext} ${PN}-editor
- newbin view_graph/viewgraph.${ext} ${PN}-viewgraph
- fi
-
- dodoc README.adoc CREDITS FAQ CHANGES
- if use doc; then
- dohtml doc/*
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}